Burning smell - El Camino Central Forum : Chevrolet El Camino Forums
El Camino Central Forum : Chevrolet El Camino Forums
 
Ground Up
User Name
Password

Reply
 
Thread Tools Display Modes
  #1  
Old 09-10-2011, 11:13 AM
elcaminothepathway's Avatar
elcaminothepathway elcaminothepathway is offline
Senior Member

Master Wrench
 
Join Date: Oct 2010
Name: Jim
Location: Blair, NE
Year: 1984
Model: El Camino
Region: 11(IA,NE,ND,SD)
NECOA #: 17741
Posts: 421
elcaminothepathway will become famous soon enough
Default Burning smell

I need help!! Every time I start my elky I have a burning smell it doesn't smell like oil or anything I have ever smelled before. Only happens in the first 5 min or running or so. The closest thing I can compare it too would be a burning belt. All my belts are tight and cannot see any signs of abnormal wear on any of them. I don't know where else to look or what to look for. Thanks for the help.
__________________
84 El Camino, restored. . . someday.

76 Scottsdale heavy half truck, seen all 49 drivable states thanks to my uncle.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-10-2011, 12:39 PM
goodcruiser goodcruiser is offline
Senior Member
Master Wrench
 
Join Date: Jul 2010
Name: Rick
Year: 1982
Model: Caballero
Region: 18(CA)
NECOA #: 17105
Posts: 1,664
goodcruiser is a glorious beacon of light
Default

When you first start it up you have the burning smell then it goes away?
Does it do it everytime when you start it up or only when cold?
What engine do you have?
Check to make sure the smog pump and the A/C are not binding up at initial start up.Be sure to try it without the A/C turned on to see if you still have the smell.
This one could be a bear to find as we're gonna need to accumulate some more info to eliminate possibilties.
Can you tell if the smell is coming from the engine compartment or is it coming from the inside of the cab?Can see any smoke even the smallest wisp would help you find where to look.
Reply With Quote Quick reply to this message
  #3  
Old 09-10-2011, 01:59 PM
Marv D's Avatar
Marv D Marv D is offline
Senior Member

Master Wrench
 
Join Date: Apr 2009
Location: Central Az
Year: 1967
Model: El Camino
Region: 15(AZ,MN)
NECOA #: 13944
Posts: 1,949
Marv D has a reputation beyond reputeMarv D has a reputation beyond repute
Default

Electrical maybe???
Take a REAL close look at the grounds between the engine and the battery. There is good reason the factory grounding scheme went ... battery to engine.... then engine to firewall and engine to frame.

I had a young man with a similar smell and all of a sudden the factory console shifter was acting 'sticky'. With the ground moved ftom the alternator bracket to the frame (to make it look better he said),, he was grounding the engine 100% through the shift cable. The shift cable was getting so hot it melted the teflon cable liner.

Just a thought.....
__________________

When you're dead, it's only a problem for the people around you, because you don't know you're dead.
.....It's kinda the same when your STUPID.....

To view links or images in signatures your post count must be 0 or greater. You currently have 0 signatures.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 signatures.


I just finished reviewing my social security statement and thanks to the current administrations handling of my SS funds,,,, I only have to work until noon on the day of my funeral
Reply With Quote Quick reply to this message
 
  #4  
Old 09-10-2011, 02:44 PM
steelybill steelybill is offline
Senior Member

Master Wrench
 
Join Date: Apr 2009
Name: Bill Creller
Location: saginaw mi
Year: 1975
Model: El Camino
Region: 9 (IN,KY,MI)
NECOA #: 13978
Posts: 11,847
steelybill has a reputation beyond reputesteelybill has a reputation beyond repute
Default

"making it look better" doesn't seem to help these cars run any better.......and all that "stuff" was installed for a reason.....
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 signatures.
Reply With Quote Quick reply to this message
  #5  
Old 09-12-2011, 02:18 PM
elcaminothepathway's Avatar
elcaminothepathway elcaminothepathway is offline
Senior Member

Master Wrench
 
Join Date: Oct 2010
Name: Jim
Location: Blair, NE
Year: 1984
Model: El Camino
Region: 11(IA,NE,ND,SD)
NECOA #: 17741
Posts: 421
elcaminothepathway will become famous soon enough
Default

Its mostly when it is a cold start up however it does happen when its hot sometimes. I start it with a/c on and off, still smells the same. I have a 305 in it, all stock. I think the smell is coming from the engine, because if I start it up and don't run the air or vent and its not as strong, However if I start running the vents or a/c it gets stronger. I understand that could be moving the smell around and making it stronger but it makes me think it is coming from the engine compartment. I think that answers most of the questions. I will look at the electrical if I see anything abnormal I will report it but I don't know exactly what to look for. Thanks for the suggestions and thanks in advance.
Reply With Quote Quick reply to this message
  #6  
Old 09-12-2011, 02:50 PM
just plain john just plain john is offline
Senior Member
Master Wrench
 
Join Date: May 2008
Location: 13(TX)
Year: 1981
Model: El Camino
Region: 13(TX)
NECOA #: 11645
Posts: 1,120
just plain john will become famous soon enough
Default

A/C clutch?
__________________
Turbo Buick/Grand National powered
To view links or images in signatures your post count must be 0 or greater. You currently have 0 signatures.
Reply With Quote Quick reply to this message
  #7  
Old 09-12-2011, 02:52 PM
elcaminothepathway's Avatar
elcaminothepathway elcaminothepathway is offline
Senior Member

Master Wrench
 
Join Date: Oct 2010
Name: Jim
Location: Blair, NE
Year: 1984
Model: El Camino
Region: 11(IA,NE,ND,SD)
NECOA #: 17741
Posts: 421
elcaminothepathway will become famous soon enough
Default

What would indicate that it would be an A/C Clutch?
Reply With Quote Quick reply to this message
  #8  
Old 09-12-2011, 03:00 PM
just plain john just plain john is offline
Senior Member
Master Wrench
 
Join Date: May 2008
Location: 13(TX)
Year: 1981
Model: El Camino
Region: 13(TX)
NECOA #: 11645
Posts: 1,120
just plain john will become famous soon enough
Default

They're usually very noisy and/or drag the belt. Does the clutch engage easily? I'm just throwing ideas out there, it's hard to diagnose a smell when you can't smell it
Reply With Quote Quick reply to this message
  #9  
Old 09-12-2011, 03:05 PM
elcaminothepathway's Avatar
elcaminothepathway elcaminothepathway is offline
Senior Member

Master Wrench
 
Join Date: Oct 2010
Name: Jim
Location: Blair, NE
Year: 1984
Model: El Camino
Region: 11(IA,NE,ND,SD)
NECOA #: 17741
Posts: 421
elcaminothepathway will become famous soon enough
Default

I understand it is hard to diagnose. I don't often turn on the a/c. I suppose it could be it is rather noisy when it engages. (kinda one of the reasons I have never used it much) If it is the a/c clutch and it has been bad for awhile why has it just started smelling now? How much is it to replace an a/c clutch on an 84 with a 305?
Reply With Quote Quick reply to this message
  #10  
Old 02-21-2017, 09:30 AM
DonGrinter's Avatar
DonGrinter DonGrinter is offline
Junior Member
Member
 
Join Date: Feb 2017
Name: Jordon Grinter
Year: 1984
Model: El Camino
Region: 18(CA)
NECOA #: 77937
Posts: 1
DonGrinter will become famous soon enough
Default Having this same Issue

I just bought a 84 and unfortunately, I'm having this same issue. Did you ever resolve this issue? If so, what was it and how much did it cost to fix?
Reply With Quote Quick reply to this message
  #11  
Old 02-21-2017, 10:25 AM
JJLT1's Avatar
JJLT1 JJLT1 is offline
Senior Member
Master Wrench
 
Join Date: Jul 2008
Name: JJ
Location: South of Houston
Year: 1985
Model: El Camino SS
Region: 13(TX)
NECOA #: 12122
Posts: 10,248
JJLT1 has a reputation beyond reputeJJLT1 has a reputation beyond repute
Garage
Default

welcome Don/Jordan

Jim hasn't logged-in in over a year, so we may never know??

if the smell comes out of the AC vents, maybe check the blower motor too..

__________________
JJ
85-SS 95-LT1-383 4L60 8.5-3.73
To view links or images in signatures your post count must be 0 or greater. You currently have 0 signatures.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 signatures.
Reply With Quote Quick reply to this message
  #12  
Old 02-21-2017, 11:22 AM
gilby's Avatar
gilby gilby is offline
Deputy Director Region 18 Participating Member


Master Wrench
 
Join Date: Nov 2007
Name: gilbert
Location: upper lake,ca.
Year: 1974
Model: El Camino Classic
Region: 18(CA)
NECOA #: 10426
Posts: 6,015
gilby has a reputation beyond reputegilby has a reputation beyond repute
Garage
Default

..maybe ya pick up a plastic bag off the road and got hung up on the exhaust pipe.!..did ya see any signs of anything that might have melted on the pipe?
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 signatures.

..1974 Conquista
..1979 GMC Caballero
..2003 Impala
..2015 Spark
Reply With Quote Quick reply to this message
  #13  
Old 02-21-2017, 11:50 AM
cffisher's Avatar
cffisher cffisher is offline
Member
Knuckle Buster
 
Join Date: Nov 2016
Name: Charlie Fisher
Location: Kalamazoo , MI
Year: 1980
Model: Caballero
Region: 9 (IN,KY,MI)
NECOA #: 75850
Posts: 58
cffisher will become famous soon enough
Default

Just a thought here. When you turn on your defroster your A/C comes on. So check the blower motor and the clutch. Could you start the car with the hood open and see if you smell it.. Start the car and look at the engine bay right away to see if anything is smoking?
Reply With Quote Quick reply to this message
  #14  
Old 02-21-2017, 02:16 PM
xlchjoe's Avatar
xlchjoe xlchjoe is offline
Site Contributor


Master Wrench
 
Join Date: Feb 2015
Name: Joe L.
Location: Da Boro of Hats PA
Year: 1971
Model: El Camino
Region: 3 (DE,NJ,PA)
NECOA #: 52961
Posts: 4,437
xlchjoe is a name known to all
Garage
Default

I would also check da battery cable to starter. May be coming apart internally and burning da outside jacket from within. Pop da hood then start it then go feel cable to see how warm it is.
__________________

And I will not be commanded
And I will not be controlled
And I will not let my future go on
Without the help of my soul


To view links or images in signatures your post count must be 0 or greater. You currently have 0 signatures.

71 Camino
02 Z28
03 Blazer
11 Vette
11 Fatboy


Reply With Quote Quick reply to this message
  #15  
Old 02-21-2017, 02:29 PM
old goat's Avatar
old goat old goat is offline
Senior Member
Master Wrench
 
Join Date: Feb 2013
Name: Rick
Location: Brainerd International Raceway
Year: 1985
Model: Conquista
Region: 10(IL,MN,WI)
NECOA #: 23551
Posts: 3,992
old goat is a name known to all
Garage
Question

Missing any cats? Good luck!
__________________
Old Goat
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Smilies
Options

Register Now

In order to be able to post messages on the El Camino Central Forum : Chevrolet El Camino Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Postal Code
Required
Street Address
Complete, verifiable Street or other address required (Hidden)
City
Your city or town
State or Province
Required
Location area within State
Which selection best describes the area of the State that you live in.
Country
Required
NECOA Region
Required
Year of Vehicle
Required
Make of Vehicle
Required
Model of Vehicle
Required
Real Name
Required. Your real name to be shown in your posts and profile.
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Does anyone know of a free dvd burning softwear El Big Joe General BS Topics 3 10-27-2007 11:49 PM
Burning question about ECM Kaballero Electrical Systems 0 02-25-2007 07:16 AM
burning up ignition modules 84camino305 Ignition Upgrades & Discussion Forum 13 01-22-2007 05:05 PM
Burning Smell when on fast Idle! eightysix Engine Topics 6 12-19-2003 12:14 PM
burning oil Matt Engine Topics 5 05-27-2003 10:36 AM

All times are GMT -7. The time now is 10:15 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Logos and trademarks on this site are property of their respective owners. Comments are property of their posters, the rest 2001-2009 by me


 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.