El Camino Central Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
once again i apolagize if this has been covered already, if so direct me to it...but about eight months or so ago i was listening to my radio and all of a sudden it just crapped out on me. and keep in mind i dont turn it up very loud. when i got out of class it still didnt work(cant blame for tryin). but i turned it all the way up and it just made a continuous barely audible humming sound...tried finding someone that could repair it or could give me some educated guess what could be wrong...no one here in pascagoula mississippi will touch it (save for an employee at Hoopers but he hasnt the time :(. however he did say it may be a transistor...i have no cluse how to identify one or replace it.... a few people at a radio shop gave me the oddest look when i asked them(their sigh said repair too...):dontknow:. its the original radio and i would rather not get a new digital with a discounted amp, which is what most everyone is telling me to get. (plus i think we all know what an "amp" doese to a vehicle...and not make it sound "better" when all the bolts are rattled loose). so good peoples of El Camino Central....WHAT NEED I DO AND WHAT DO YALL THINK IS WRONG WITH IT? thank you in advance
 

·
Registered
Joined
·
1,810 Posts
Does humming change with engine rpm or different radio stations? Crawl under there and find the speaker wires (paired). If those look good and undamaged. Check the speaker cone, is it broken or separated ? If all is good, Then I would locate a speaker that works and bring to Elk and connect it to speaker wires. If that works, it's your speaker. If not, go to radio.
 
1 - 2 of 2 Posts
Top