El Camino Central Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Hi I'm new and I just got a 77 el camino and it was runing fine but now it will only run for about 30 to 40 second before dying. When it's idling if u try to give it gas it dies instantly.I'm also find it hard to start at times pumping the gas pedal work sometimes .The other time I have to pure gas into carb directly. I also installed a new gas pump. Please help if u can cause i really want to drive my vehicle
 

·
Registered
Joined
·
132 Posts
If it's a mechanical fuel pump make sure you installed the lever in the propery position. First though you need to remove fuel line from carb and see if it's even getting more than a dribble of gas. Filter may be pluged, carb float may be stuck etc. Try the simple stuff first.
 

·
VINTAGE MOTORHEAD
Joined
·
4,103 Posts
Welcome from Florida! X2 on checking out all your fuel lines and replace filter. Make sure your fuel tank cap vent is working if you have a vented one. Have you pulled a plug to eyeball what they look like? Are they sooty /brown/white?:dontknow:
 

·
Deputy Director, Region 25 Site Supporter
Joined
·
2,759 Posts
If you still have no luck after trying what the other guys suggested,check to make sure that the escentric on the camshaft has not worn down.
 

·
Registered
Joined
·
70 Posts
Did this problem start after you put the new fuel pump on? That pushrod for the pump can be a real ***** to get right if the lobe is all the way "up". Crank the engine over (tap ththe key) to get to the backside of the lobe.
 

·
Premium Member
Joined
·
12,560 Posts
If it's a mechanical fuel pump make sure you installed the lever in the propery position. First though you need to remove fuel line from carb and see if it's even getting more than a dribble of gas. Filter may be pluged, carb float may be stuck etc. Try the simple stuff first.
WE have a winner!!!:beer:
Donny
 

·
Registered
Joined
·
1,810 Posts
Now there might be another filter near the tank. You should have a filter before and after the pump. I recommend you replace all your fuel lines if they are original, your filter may be picking up old line crud, check in 1 month time, if the filter is clogging up again its the lines.
 
1 - 8 of 8 Posts
Top