El Camino Central Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
860 Posts
Discussion Starter · #1 ·
Well I found my a/c ventilation problem. The vacuum part of my control is bad. Can I buy just this part or do I need to find the whole thing. Everything else on it works fine. I can jump across the tubings and make everything work. If somebody has an OEM number on it I could try that.
Thanks, Tom
Toy Motor vehicle Metal Office equipment Machine
 

·
Deputy National Director
Joined
·
9,613 Posts
The 9 port vacuum switches are hard to find, nobody makes new ones, can try a used but they could be bad, new ones on Ebay they want over $100 for them, heard you can rebuild them ????? Check internet for that ??

I would give part # but don't have my computer back from getting fixed

Check with Matt @Kamino60 & see if he has a used one ? If you want to go that route ?
 

·
Registered
Joined
·
860 Posts
Discussion Starter · #3 ·
Found that mine has a broken clip holding it together. Going to try this tomorrow.
Tom
Light Product Wheel Automotive tire Font
 

·
Registered
Joined
·
864 Posts
Here is a great video to help rebuild the AC control on our 5th Gens. Actually, all of the videos by Hutch have proven to be well-worth watching.

 

·
Senior Member - 2019 Exceptional Action Award
Joined
·
746 Posts
The 9 port vacuum switches are hard to find, nobody makes new ones, can try a used but they could be bad, new ones on Ebay they want over $100 for them, heard you can rebuild them ????? Check internet for that ??

I would give part # but don't have my computer back from getting fixed

Check with Matt @Kamino60 & see if he has a used one ? If you want to go that route ?
The 9 port vacuum switches are hard to find, nobody makes new ones, can try a used but they could be bad, new ones on Ebay they want over $100 for them, heard you can rebuild them ????? Check internet for that ??

I would give part # but don't have my computer back from getting fixed

Check with Matt @Kamino60 & see if he has a used one ? If you want to go that route ?
Wheel Vehicle brake Locking hubs Automotive tire Bicycle part
Musical instrument Musical instrument accessory Electronic instrument Music Audio equipment
 

·
Premium Member
Joined
·
6,012 Posts

·
Registered
Joined
·
860 Posts
Discussion Starter · #7 ·
Thank you Kamino60. It looks like yours is missing the clip. I will try the bolt and nut thing tokay. Mine works if I can keep it tight.
Tom
 

·
Registered
Joined
·
874 Posts
I went through this exact thing last year in my '82. The nut and bolt trick didn't work for me personally but I found the cheapest place to get one was actually through one of the dealer parts houses. The part is discontinued but they still had a few last I looked.
 

·
Registered
Joined
·
860 Posts
Discussion Starter · #10 ·
Well, the nut and bolt seems to be working , but I am on the lookout for a replacement. It seems the silicone grease works wonders. Ace hardware had the truss head bolt and nylon lock nut. $.48
Tom
 

·
Registered
Joined
·
860 Posts
Discussion Starter · #11 ·
I went through this exact thing last year in my '82. The nut and bolt trick didn't work for me personally but I found the cheapest place to get one was actually through one of the dealer parts houses. The part is discontinued but they still had a few last I looked.
Did you use the AC Delco part # when talking to them?
Tom
 

·
Registered
Joined
·
295 Posts
From what I am being told you can still get this through a Chevy dealer. Special order out of Canada. P/n GM 16037778, ACDelco 15-71389. 9 port switch.
Price $131.62 Yikes!!!!
 

·
Registered
Joined
·
874 Posts
From what I am being told you can still get this through a Chevy dealer. Special order out of Canada. P/n GM 16037778, ACDelco 15-71389. 9 port switch.
Price $131.62 Yikes!!!!
Try through one of the online wholesale GM parts places. I think this is where I got mine through. It's part of the dealer network minus the dealer markup for parts.
 

·
Registered
Joined
·
25 Posts

·
Registered
Joined
·
860 Posts
Discussion Starter · #16 ·
Thanks for posting for me. All my electric is good. It’s the vacuum 9 tube switch that the problem was.
Tom
Product Font Screenshot Technology Engineering
 
1 - 16 of 16 Posts
Top