El Camino Central Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
Very little air comes out of my air conditioning vents even with the fan on high. I've replaced the blower motor, but it had a negligible affect on it. The air coming out of the heater seems to really blow well when it is in this position. What could be the problem?
 

·
Super Moderator
Joined
·
4,363 Posts
What year car are we talking about here?
 

·
Super Moderator
Joined
·
4,363 Posts
You need to check and verify your vacuum source to your a/c heater control switch. Just below the blower motor housing you should see two vacuum lines exiting the firewall, one will be attached to the heater control valve on one of your heater hoses, and the other will be attached to the intake manifold, (this is the one to check.)

Lemme know what you find.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #5
Thanks for your help.

Vacuum source appears to be good. The doors seem to operate properly, moving the air flow from the floor vents to the dash to the defroster vents as I move the lever between the various positions though when I switch to "vent" there is often a loud "thunk" when the door operates.

When I replaced the blower motor I checked as well as I could for foreign material that might be clogging things up, but there wasn't much to remove. The air flow through the floor vents seems to be quite high velocity, but the dash vents are pretty meager.
 

·
Registered
Joined
·
20 Posts
the door for the vent mode is off its motor you will have to take the box out and open it ans reattache it if its not on the vac motor
let me know if you need a print on how to do it and i will look it up in my aldata system
 

·
Super Moderator
Joined
·
4,363 Posts
fordrod said:
the door for the vent mode is off its motor you will have to take the box out and open it ans reattache it if its not on the vac motor
let me know if you need a print on how to do it and i will look it up in my aldata system
Good suggestion, however, if the servo motor were not attached to the door, he would not hear the thunking noise when actuating the corresponding mode.
 

·
Super Moderator
Joined
·
4,363 Posts
This is a pretty common problem with G-Bodies. I have repaired several over the past 20 years or so being in the auto a/c business. My own 87 SS Elky is in need of this service as soon as I have time to get around to it. Summer is almost over and I will have plenty of time to fiddle with it this winter. Anyway, here is a link to someone else who has had experience with this same issue.

3rd and 4th generation Monte Carlo stuck dash vents fix
 

·
Super Moderator
Joined
·
4,363 Posts
fordrod said:
forward info on your car to [email protected]
i will be glad to sent you the info and pics
steve
Steve, submit them to the site and we will post them in the a/c and heating topics section as well. I could even photo and document the repair I do on my 87 and write up as an article.

Thanks
Robert
 
1 - 15 of 15 Posts
Top