El Camino Central Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
380 Posts
Discussion Starter #1
All of a sudden the AC compressor won't kick in and the blower motor won't work either on my 82 El Camino.

First thing I did was check the fuse. It was good but replaced it anyway. No help.

Replaced the blower motor resistor with a new one after checking the old one which was bad but still no help.

Took the relay off and removed the metal cover, looked ok, not burnt or anything, so I put it back on the car. How can you tell if it's bad?

There is no fan at either low, med., or high speed and AC compressor clutch won't kick in.

Would a bad fan switch on the heater controls prevent all this from working?

I actually took the two switches in the heater control assembly apart. There's really not much to them and I can't really see anything there to go bad. Again, how can you tell if these switches are bad?

What should I check next?
 

·
Premium Member
Joined
·
851 Posts
power to the relay? and/or to the blower motor?
Don't forget to verify grounds...
 

·
Registered
Joined
·
380 Posts
Discussion Starter #4
Thanks Robert!
If it is the switch thats bad, which switch are you referring to, the fan switch (one that goes up and down) or the mode selector switch (that goes side to side)?
 

·
Vendor
Joined
·
4,363 Posts
Mode switch, side to side.
 

·
Registered
Joined
·
380 Posts
Discussion Starter #6
Robert,

Well, you nailed that one for me! I tracked down that brown wire to the plastic connector and sure enough, it had gotten too hot and melted some of the plastic and corroded some.
What causes it to get hot like that and what can be done to prevent it, anything?
Would an inline fuse be better and if so what amp?
Thanks so much for your advice!
 

·
Vendor
Joined
·
4,363 Posts
What causes it to get hot like that and what can be done to prevent it, anything?
Worn out blower motors, replace.
 

·
Registered
Joined
·
380 Posts
Discussion Starter #8
Roger that! I'll check it. Thanks again for your advice!
 

·
Registered
Joined
·
1 Posts
I have an 87 with the 4.3 and my ac compressor is bad can i disconnect the belt for now to stop the squealing noise or will that affect other things like the heat or anything
 
1 - 9 of 9 Posts
Top