El Camino Central Forum banner
1 - 11 of 11 Posts

· Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hello all, Have a 68 el camino here that is an automatic with 307, NON power steering and non ac currently (not sure if it was a factory ac car or not), and a short water pump. Currently the alt is mounted with a universal kit that has a LONG arched bar with adjust slot and other half mounts to header bolts. The thing is adjusted all the way and belt is very loose. My question is what bracket set up would be correct, alt is currently mounted up high on driver side by the way. Dont really care who makes the bracket but there are so many diffrent ones to choose from its confusing to find by looking at magizines . Does anyone have a pic of the same set up ?
 

· Registered
1984 GMC Caballero
Joined
·
2,206 Posts
Have you tried to get a shorter belt for it. What you have sounds about right for the brackets for those years. You may have to try a few shorter belts till you find one that tightens with the inner area of the bracket. Mine is an 84 with a different type of bracket but I am sure there are some who have what you have and may even have the belt # for you.
 

· Registered
Joined
·
2,102 Posts
the long arm top bracket, short water pump set up was used until 69. the header bracket was a universal piece that came with the headers. the original bottom bracket bolted to the stock exhaust manifold on the driver side. just try getting shorter belts untill you get a good fit
 

· Registered
Joined
·
13 Posts
Discussion Starter · #6 ·
We would like to change the brackets to somthing better, as the long rod only has one bolt holding it on so after a little while the tension from the belt will slowly pull the rod towards the alt, loosining it. So when looking for other set ups I just need to look for short water pump high mount and driver side correct ? As far as a shorter belt, right now there is only about 3/4 to maybe one inch or clearence between the alt and the valve cover, so not sure if a shorter belt would work ?
 

· Registered
Joined
·
13 Posts
Discussion Starter · #10 ·
Ha Ha ! Thank god my buddy who bought it dosrnt know much about cars yet ! The radiator overflow hose is not going to anything but the ground, that explains him seeing coolant on the ground, not sure how he thought it was under the header but I think its all good as far as that. Will update tomorrow hopefully with some pics.
 

· Registered
Joined
·
13 Posts
Discussion Starter · #11 ·
Got done putting on a shorter belt < 3/4 and that seemed to work out ok. Totally forgot to take pics because I got excited when we started fixing the electrical connectors and stuff. As long as the belt holds I think I will just keep my eye out for a set up that looks better and is cost effective (probally not). Thanks for all your help on this topic
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top