El Camino Central Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hey guys I just had my carb rebuilt and it runs better than ever a few things I’ve notice is when I’m at a stop and I begin to turn and push the gas slightly it hesitates for a quick second and does a little pop. The engine also has a little shake at idle and I can hear the engine surging in park.. can this be a ignition problem? Or a timing issue? I was grinning rich before my carb got rebuilt and got a new mixture control solenoid because the other one wasn’t working
 

·
Premium Member
Joined
·
5,762 Posts
surging idle is usually a sign it is a little lean. gradually slide your hand over the air horn to restrict the air a little and see if it doesn't smooth out.
If it does you might just need to adjust the idle mixture screws.
 

·
Registered
Joined
·
1 Posts
Hi all. Just acquired a 1980 El Camino 6 cyl and am experiencing the same thing. Engine idles prrfect but starts misfiring when I accelerate. Is this a common problem? I hear what sounds like a loose valve rod and engine runs sluggish..
Can it be a bad intake gasket? Engine starts right up and idles prrfect. Pls advise...anyone?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
Hi all. Just acquired a 1980 El Camino 6 cyl and am experiencing the same thing. Engine idles prrfect but starts misfiring when I accelerate. Is this a common problem? I hear what sounds like a loose valve rod and engine runs sluggish..
Can it be a bad intake gasket? Engine starts right up and idles prrfect. Pls advise...anyone?
I’m kinda going thru that problem now but yet no one has helped me. I just got my carb rebuilt and I was facing a lean condition after it so I richen the fuel mixture and the problem went away but I think I richen it too much because now I have a check engine light when I idle to long. Just be careful when you richen the fuel mixture
 
1 - 5 of 5 Posts
Top