El Camino Central Forum banner

1 - 16 of 16 Posts
B

·
Guest
Joined
·
0 Posts
Discussion Starter #1
my 84 elky blinker switch has fallen all apart so the cruze controll and wipers dont work. i bought a new one from orileys for a non cruze car and the two keys that slide down in the slots in the column are too close togeather. are the cruze and non cruze peices diffrent?
 

·
Deputy Director, Region 1
Joined
·
2,566 Posts
I would think cruise has an extra wire or 2. So one w/o should have less wires and fit anyway. The columns and shift bowls are the same either way.
 

·
Registered
Joined
·
2,102 Posts
i have never tried to interchange them but i dont think thier different.the pulse and non pulse wiper switches are different so they might be
 

·
Registered
Joined
·
11,510 Posts
don't forget to add new blinker fluid too! Running them dry is why they fall apart like that!

:poke:
 

·
Vendor
Joined
·
4,363 Posts
No difference, one will interchange with the other.
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #7
well your telling me that they should interchange but i know it wont because the new arm wont fit. the slots are two far apart. i might try to hit the junk yard tomorow. what other cars would have the same one? maybe s10?
 

·
Premium Member
Joined
·
5,893 Posts
Are you trying to put the turn signal lever back in? The wiper notch on the outside rotates. You have to turn them to align them with the grooves in the housing.
 

·
Deputy Director, Region 1
Joined
·
2,566 Posts
Ahh..I thought you couldn't feed the harness into the column.
That little black plastic part that the arm goes into is the same from 78-88. And there were a few different signal arms. Some early ones are plain, some have cruise, some are just wipers, some are cruise and wipers but they all fit the part inside the column. Even different lines will fit others. You can Buick in Chevy, Olds, Pont, etc. and vice-versa.
Do as 464 said twist it until they line up.
 

·
Vendor
Joined
·
4,363 Posts
Twist it till it fits.
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #11
the problem isnt getting the arm in the column. the new one i ordered from orileys has the two teeth too far apart to fall in the holes in the column. i guess the new part is the wrong one or made wrong
 

·
Deputy Director Region 6 - Supporting Member
Joined
·
6,209 Posts
Sounds like made wrong. It should have went in just opposite of the way the old one came out.
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #13
yeah the part was made wrong. went to the junkyard just now and found one out of a 97 firebird that fits perfect. its a little diffrent design but it works. now when i turn the wipers on all it does is click:( whqats this mean?
 

·
Deputy Director Region 6 - Supporting Member
Joined
·
6,209 Posts
Try a contact clean on switch and in column and go again. If you had intermittent wipers and the switch you are putting in doesn't??? That part I don't know. A switch without cruise makes no difference to signals and wipers...Just no wire to feed down through the column.
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #16
ive never had the wipers working. im going to check if the wiper motor has power tomorow. thanks for all yalls help!
 
1 - 16 of 16 Posts
Top