El Camino Central Forum banner

1 - 16 of 16 Posts

·
Senior Member Participating Member
Joined
·
398 Posts
Discussion Starter #1
Last year my 84 Air Conditioner was getting touchy.The fan sometimes would not work on low.So a light tap on the blower motor,and everything was O.K.This year (Yesterday) it only works on high.No medium or low.Tried tapping.Should I get a bigger hammer or,is it time for a new blower motor????:violin:C.J.
 

·
Registered
Joined
·
4,135 Posts
Hey C.J. if you were tapping on the motor to make it work, its a goner.

Time for a new one.
 

·
Senior Member Participating Member
Joined
·
398 Posts
Discussion Starter #3
Thank's Sean,sorta figured that.Time to call NPD.See you in October.cj
 

·
Director Region 6 (FL) - 2017 Founders' Award Reci
Joined
·
4,609 Posts
I did not think that a real Marine like you even used an air conditioner :dontknow:
 

·
Registered
Joined
·
388 Posts
I'd look at the blower motor resistor before I would change the motor.
 

·
Senior Member Participating Member
Joined
·
398 Posts
Discussion Starter #6
Lenny,it's not me ,it's tootie!!!!!:let_it_all_out:She said "Do you want to ride all the way to Ocala with the windows down"?
 

·
Senior Member Participating Member
Joined
·
398 Posts
Discussion Starter #7
I will check the resistor first.Thank's cj
 

·
Senior Member Participating Member
Joined
·
398 Posts
Discussion Starter #8
O.K. the resistor is good. I ordered and installed a new motor.STILL NOTHING on LOW or MEDIUM.Fan only works on HIGH.Should I try the switch??:let_it_all_out:
 

·
Senior Member Participating Member
Joined
·
398 Posts
Discussion Starter #10
I will do that.thanks for the info.I grew up and worked in G.R. Retired Steelcase driver
 

·
Banned
Joined
·
5,787 Posts
the relay is a high speed only step up relay your problem is in the switch or harness, trust me, ask me how i know:beer:
 

·
Registered
Joined
·
1,502 Posts
A few minutes with a Volt-Meter to trace out the Circuit is faster & cheaper than throwing parts at it!
Back to Basics...Start by checking all Grounds by doing a Voltage-Drop across them...Clean them just for drill. Then go to the Fuse block and work your way to the problem...
 

·
Senior Member Participating Member
Joined
·
398 Posts
Discussion Starter #14
And the winner is:nanawrench: I replaced the motor.(still the same) I replaced the resistor (still the same) I replaced the switch,(still the same)Would you believe THE RELAY!!!:beer: I do have a couple of slightly used New parts for sale.Thank's to everyone that responded. C.J.
 

·
Deputy Director Region 6 - Supporting Member
Joined
·
6,209 Posts
And well now you are cool again. And Tootie can stand to be with you on long rides:poke:.

:beer:
 

·
Registered
Joined
·
281 Posts
Blower motor

Semper glad your issue is solved. Ive worked near steelcase for 35 years, always loved the looks of there fleet. Was sorry about there business issues. Have alot of coworkers that transfered to them for the bonuses and lost their jobs a few years later. A real blow for the local economy.
 
1 - 16 of 16 Posts
Top