El Camino Central Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
178 Posts
Discussion Starter #1
Hi everyone,

Car is 81 SS but the engine (for now has to be) is 86+ computer controlled carb. I have a bit of a problem getting it to run just right.

When all warms up it seams to be spurting and stumbling little bit. Vacuum gauge indicates late timing and needle wanders 2-3 psi within that range along with RPMs.

Sometimes when i REV it on idle a bit high it comes to senses and vacuum stabilizes along with RPMs and it runs perfect until i shut down and restart the engine.

Also when i disconnect (4 wire flat) plug for computer to carburator ( the one you disconnect when you set up timing) it stabilizes RPMs and runs nice (throws a code of course) and when i reconnect it goes back to ape****.

Any suggestions? any questions to help diagnose the issue? :You_Rock:
 

·
ZERO MPG
Joined
·
15,367 Posts
Hi everyone,

Car is 81 SS but the engine (for now has to be) is 86+ computer controlled carb. I have a bit of a problem getting it to run just right.

When all warms up it seams to be spurting and stumbling little bit. Vacuum gauge indicates late timing and needle wanders 2-3 psi within that range along with RPMs.

Sometimes when i REV it on idle a bit high it comes to senses and vacuum stabilizes along with RPMs and it runs perfect until i shut down and restart the engine.

Also when i disconnect (4 wire flat) plug for computer to carburator ( the one you disconnect when you set up timing) it stabilizes RPMs and runs nice (throws a code of course) and when i reconnect it goes back to ape****.

Any suggestions? any questions to help diagnose the issue? :You_Rock:
[II'm dialing mine in could be your 02 sensor/knock sensor what codes are you getting? Mine didn't like the timing set at 6BTDC so I bumped it to 8 BTDC and she runs a lot better.:dontknow: I had my carb. rebuilt the floats were sticking kinda the same issue your having?[/I] Same thing with the plug disconnected mine ran better unplugged till had the carb. rebuilt.
 

·
Registered
Joined
·
12,533 Posts
the 4 wire flat plug,,the one you disconnect when you set up timing,,
should be at the distributer,, pass side usually..

sounds like the esc is ether retarding the timing or the initial timing is too high,,cant really tell..:dontknow:
check the timing with it connected and disconnected and see what it is..
try setting it around 0-5* plug the plug back in, and clear the codes.. :texas:
 

·
Registered
Joined
·
178 Posts
Discussion Starter #4
[II'm dialing mine in could be your 02 sensor/knock sensor what codes are you getting? Mine didn't like the timing set at 6BTDC so I bumped it to 8 BTDC and she runs a lot better.:dontknow: I had my carb. rebuilt the floats were sticking kinda the same issue your having?[/I] Same thing with the plug disconnected mine ran better unplugged till had the carb. rebuilt.
1. Carb is fresh. Rebuilt to specs for SBC 305 by national carburators (ebay outfit)
2. o2 sensor NEW with stock manifolds
3. Engine got knock sensor in the block but I can seam to find plug for it, nor any hanging wires where plug supposed to be ... Did 81-84 harness had provision for knock sensor? were they used then?
4. Timing ... just guessing because harmonic balancer doesnt have a timing tape on it so I got it set to when it has best vacuum 21-22 and holding and then connect the plug


Help
 

·
Registered
Joined
·
178 Posts
Discussion Starter #5
the 4 wire flat plug,,the one you disconnect when you set up timing,,
should be at the distributer,, pass side usually..

sounds like the esc is ether retarding the timing or the initial timing is too high,,cant really tell..:dontknow:
check the timing with it connected and disconnected and see what it is..
try setting it around 0-5* plug the plug back in, and clear the codes.. :texas:
Hard to tell specifically with this balancer and timing tang. Balancer doesn't have a timing tape so I set initial timing based on best vacuum reading. And when it's stumbling vacuum reading indicated slight retardation (both of the engine and the owner) and hops around by 2-3 psi of vacuum within 16-19 psi range

help
 

·
ZERO MPG
Joined
·
15,367 Posts
1. Carb is fresh. Rebuilt to specs for SBC 305 by national carburators (ebay outfit)
2. o2 sensor NEW with stock manifolds
3. Engine got knock sensor in the block but I can seam to find plug for it, nor any hanging wires where plug supposed to be ... Did 81-84 harness had provision for knock sensor? were they used then?
4. Timing ... just guessing because harmonic balancer doesnt have a timing tape on it so I got it set to when it has best vacuum 21-22 and holding and then connect the plug


Help
I'm pretty sure if your timing it with the vacuum gauge you want the plug connected to the dist. when adjusting. IF you have the knock sensor it needs to be plugged in or you'll never get it right. I'm still learning but I was told the dist. plug needs to be connected . When I set my timing with the light it was unplugged and set it to 8 btdc reconnected it then hooked up the vacuum gauge and I'm at 18/19 vacuum plugged in. That could be one of your problems but I'm going by what another member showed me. Double check first.!!!:dontknow::dontknow: Mines running good but I want my new engine perfect. It should be there's nothing more than a year old under my hood.


I have a complete set of timing tapes I never used if you need them just PM me your address and there in the mail tomorrow no charge!!!
 

·
Registered
Joined
·
178 Posts
Discussion Starter #7
I have checked (even though it little dark) and I do not have ESC module ... nor I have plug for it. I don't see dk. blue wire just tucked or hanging loose that i could connect to my knock sensor.

Hate when harness, engine and car itself are years mismatched.

help?
 

·
Registered
Joined
·
178 Posts
Discussion Starter #9
sounds like too much timing..
from what i read the early computers may or maynot have a knock sensor..
could be a mismatch between the computer and the distributer..:dontknow:
On the other hand it would not be running right at all ... working out those minute hickups is the work alright ...

Anyone wants to pitch in their 2,4,8 and other multiplications of 2 cents?:You_Rock:
 
1 - 9 of 9 Posts
Top