El Camino Central Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
326 Posts
Discussion Starter #1
I just replaced the A/C control head and fan motor on the Elky, because it wouldn't blow. I found out why. There was a corroded wire in the harness that leads to the blower control box. I cut, stripped, and spliced in a 14ga wire and now it blows!

Unfortunately, the dash vents have no air flow. The defrost vents and the floor vents blow like gangbusters, but that's it. It seems as if there are some colored vacuum hoses that come out of the control head and connect via a friction push connector to the same colored hoses that lead to the vent control diaphragms.

Does anyone know which color controls the dash vents? I am about to use a can of air to blow into each one to see if there is a crack/break in one of them. Maybe that will help me pinpoint the problem.

Any help would be appreciated. Thanks!
 

·
Registered
Joined
·
281 Posts
colored hoses

If its like my 80,orange to passenger side diaphram,red to the passenger side of center diaphram,yellow to drivers side of same diaphram,blue to drivers side diaphram.
 

·
Supporting Member
Joined
·
4,528 Posts
Check to make sure you have vacuum coming from the engine bay. Typicall reason for no dash air is no vacuum ( vac ball removed?). Vacuum on the purple line coming in to the control head, vacuum out on the grey line back to the control valve on the heater line ( if you still have that) .
 

·
Premium Member
Joined
·
1,324 Posts
Contact acauth1, as he's the ac authority here. Big boost, he's in Round Rock, and he does good work. An added bit: he's a nice, easy-going guy and well worth knowing.
 
1 - 4 of 4 Posts
Top