El Camino Central Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 87 El Camino with a 305. When I got the truck the cruise control worked ok. Went on a 200 mile trip and I had no issues with the cruise at all. I went on a short trip and it stopped working. Also the intermittent wipers stopped working. (The regular wipers are ok) I changed the turn signal arm with the wiper and cruise controls. The wipers and cruise still don’t work. I checked under the hood to see if there are any loose wires etc. Can’t find anything wrong.
 

·
Deputy Director Region 6
Joined
·
8,665 Posts
cruise could be a broken cable ? & the wipers is most likely the circuit board, that is the major problem when they go out, I just changed my wiper motor, Can't buy a new one, the used ones are from 84-87 G-Body only
Maybe some of the experts my chime in to help diagnose them better ?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
cruise could be a broken cable ? & the wipers is most likely the circuit board, that is the major problem when they go out, I just changed my wiper motor, Can't buy a new one, the used ones are from 84-87 G-Body only
Maybe some of the experts my chime in to help diagnose them better ?
Thanks for the fast response. I checked the cable and it appears to alright but I’ll check again, maybe I missed something. Does the cruise control and the wipers share the same circuitry? The reason I ask is because the cruise and wipers went out at the same time?
 

·
Registered
Joined
·
225 Posts
How carefully did you route the new turn signal lever wiring through the column? There's a plastic sleeve that it has to go through so that it doesn't get bound up or pinched by tilting/turning etc. I know it's a pain, I did it a few months ago on my '87. Seems to me that wire is only for the cruise control (it has a unique plug-in tab at the end), as the turn signal lever locks into the switch inside the column, which in turn controls the signaling / returns the lever, etc.
 

·
Registered
Joined
·
1,446 Posts
After having three of those 70s and 80s GM cruise controls go haywire on me I can't disconnect them fast enough..
 
1 - 7 of 7 Posts
Top