El Camino Central Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter #1
Just bought an '84 Conquista. The original 305 with 4 barrel was replaced with a new '02 350 HO Deluxe. Cruise is not working. Guy I bought it from said he doesn't think it was ever hooked up after the engine was switched. He bought it from the guy who did the restoration and had the engine installed.

Would the cruise from the original engine work with the replacement?
Would it take any adapters modifications to connect it?
What should I look for,to tell if it was left disconnected, or was connected and just isn't working?

Thanks,
Don
 

·
Deputy Director Region 6 - Supporting Member
Joined
·
6,209 Posts
I think if all the components are there it should work. But since the Servo was atop the old engine you may be missing several parts. Start by a checklist to see what you have and don't have...Does the turn signal lever have a cruise switch? If so all of the stuff inside the cab may be there. A repair manual with illustrations as well as diagrams may help. The Haynes one is #24020. It won't be in stock, but you can order it through Advance Auto Parts online. Post for what you need when you have the list and you should get replies. Lots of members remove all of the cruise stuff but hang on to it just for someone like you...lol

And welcome aboard by the way!

:beer:

Oh yes the Haynes manual will be for available (like original) engines. Hook up from servo to current carb may be the only difference.
 

·
Deputy Director Region 6
Joined
·
8,953 Posts
Welcome to the site from Florida !! :florida:
 

·
Registered
Joined
·
159 Posts
Here are pictures of most components and the wiring harness for the cruise control on the 1984 El Camino. You can then decide if you have all the necessary parts.





 

·
Registered
Joined
·
51 Posts
Discussion Starter #6
Just ordered a searchable cd from Amazon of the original shop manual published by Bishko Automobile Literature. The cd is 36.00, the paper manual was around 134.00 at the ECstore.
 

·
Registered
Joined
·
51 Posts
Good Stuff...I just replaced my switch while tightening my column (all 4 bolts :wink1:) Not working yet but this will help.
 
1 - 7 of 7 Posts
Top