El Camino Central Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Replaced 305 in my 1984 Camino with older 350 and eliminated computer about a year ago. No problems untill now. If battery is not disconnected after driving willl be dead in the morning. Have checked for shorts under the hood no luck, removed fuses from box and still shows draw on battery with light between cable and battery. Anyone had this problem?
 

·
Deputy Director Region 6
Joined
·
8,781 Posts
Welcome from Florida !! :florida: Got any pics ??
You might want to do a search (up top under ASSOCIATION) for battery draw ! There is a few other guys asked that question !
 

·
Registered
Joined
·
2,527 Posts
Welcome Larry! Always good to see another region 8 member post up!! The light & the battery, it is on the negitive side cable between the battery & cable correct? The doors closed so the door switch does not trigger the light, I am just tryin` to verify the things I would do to solve this,, how about the glove box light and did your 84 come with a under the hood light,, are you near Columbus by chance?? I am in Grove City,, hope to meet with ya this summer,, Matty man
 

·
Deputy Director, Region 1
Joined
·
2,566 Posts
What about a sticky power window or door lock switch?
 

·
Registered
Joined
·
643 Posts
I had an alternator that charged while driving. But would drain my battery when turned off. I search for a short never found one. Replaced alt short was in the alternator
 
1 - 6 of 6 Posts
Top