El Camino Central Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
My son's 83 El Camino is having some issues. The engine will randomly die. There is a pause once in a while after stepping on the gas before seeing acceleration. Any thoughts/ideas on what these symptoms may be resulting from? Thanks in advance for any feedback.
 

·
Registered
1987 Stock 305. TX car in the UK
Joined
·
236 Posts
I'm no mechanic, and I'm sure someone more knowledgeable will be along presently to offer advice, but have you checked for vacuum leaks? Is it running noticeably rich?

Also, what engine is in the vehicle, and under what conditions does the stalling occur - hot, cold, both etc
There are a number of possible causes, so any more information you can provide will help with diagnosis.
 

·
Deputy Regional Director, Region 13
Joined
·
6,622 Posts
is it immediately cutting off, or is it sputtering to death? the first would indicate an electrical issue while the second would indicate a fuel issue
 

·
Registered
Joined
·
2,390 Posts
Like Ray said, if it’s running rough and stumbling, then dies, I’d be looking for vacuum leaks first, then fuel delivery. If it goes from tip top to dead like flicking a switch, that’s electrical.
Patrick
 

·
Registered
Joined
·
1 Posts
I ounce had car that idled perfectly when I got on the road and accelerated it would cut out. Turned out to be feed line from fuel pump to carburetor. the fibers had frayed inside the fuel line. every time fuel pressure increased the fibers plugged the fuel line.
 

·
Registered
Joined
·
139 Posts
My son's 83 El Camino is having some issues. The engine will randomly die. There is a pause once in a while after stepping on the gas before seeing acceleration. Any thoughts/ideas on what these symptoms may be resulting from? Thanks in advance for any feedback.
Check the filter inside the Quadrajet carb, if that’s the carb you have?
 

·
Registered
Joined
·
3 Posts
My son's 83 El Camino is having some issues. The engine will randomly die. There is a pause once in a while after stepping on the gas before seeing acceleration. Any thoughts/ideas on what these symptoms may be resulting from? Thanks in advance for any feedback.
Possibly “Crud” in the Gas Tank…And the “Sock” on the end of the pickup May be “Gummed up”..
Mike😎 69 Elc.
 
1 - 14 of 14 Posts
Top