El Camino Central Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
745 Posts
Discussion Starter #1
For the past year or so I've had smoke coming from my exhaust. Everyone said I was burning oil due to bad rings or valve seals. And I was adding a quart of oil every 1000 miles. Well, I recently switched from 20w-50 conventional to 10w-30 amsoil synthetic, and while there is still smoke I have not lost any oil in the 500 miles since the change. My question is this: since the smoke is still present but am losing no oil, could the smoke be from a bad transmission modulator? I have noticed a sweet smell from the exhaust..

Sent from my DROID RAZR using AutoGuide.com App
 

·
Deputy Director, Region 1
Joined
·
2,566 Posts
Sweet smell sounds like coolant. Have you checked that?
 

·
Registered
Joined
·
745 Posts
Discussion Starter #3
Yeah, but it isnt the same sweet smell as coolant. I have noticed that if i start the car and rev it in park, it only smokes when it goes back to idle... and only for a few seconds of heavy smoke. And idle you cant see it unless you actually look in the tailpipe

Sent from my DROID RAZR using AutoGuide.com App
 

·
Registered
Joined
·
4,135 Posts
Check the trans fluid level, but burning trans fluid stinks.

Not a sweet smell at all.

My guess is valve guides with maybe a little coolant mixed in.
 

·
Registered
Joined
·
745 Posts
Discussion Starter #5
I have to add a pint of tranny fluid every 2-3 weeks. Ive had people behind me say it stinks bad, ive smelled it before and i started to cough bad for 5 minutes

Sent from my DROID RAZR using AutoGuide.com App
 

·
Registered
Joined
·
4,135 Posts
Sounds like its time for a new vac modulator.
 

·
Registered
Joined
·
2,102 Posts
trany fluid usually makes white puffy smoke. disconnect the modulator line and let it runn to see if the smoke clears up or if there is oil in the line at the trans the modulator is gone
 
1 - 8 of 8 Posts
Top