El Camino Central Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
929 Posts
Discussion Starter #1 (Edited)
I have had a high idle problem for awhile, but it would appear spontaniously and rarely, and it the car dieseled it would shortly after turn off. Today it got really bad, the cruck didn't come with a tachometer, but it was idling way too high. It continued while I was driving, and was enough to push me 25mph without touching the gas. When I pulled into the gas station to take a look, it would NOT shut off, would just keep dieseling until I took the air cleaner cover off and choked it. I get home, try shutting it off, have to choke it again. Check the A/C idle, no problem, then I check the high idle cam, and when I pushed it down the idle returned to normal, but then when I would give it throttle, the high idle cam would kick back up and begin the high idle again.

So it seems like my high idle cam is getting stuck, but whenever I get it unstuck, once throttle is applied it kicks back in and begins the high idle again.

Thanks for any help!
 

·
Registered
Joined
·
929 Posts
Discussion Starter #2
Just noticed the ticking noise you hear right before you start the car continues while the its running.
 

·
Premium Member
Joined
·
336 Posts
My high idle cam was sticking earlier this year (my AC idle solenoid was also kicking in randomly a month later too!). Every time I hit the throttle it would stick and cause a high idle.

I just got some carb cleaner and sprayed it a few times, wiggling it back and forth. After a few times of doing that, it has been fine ever since. Not sure if you tried that, but get some carb cleaner and just wiggle the linkage a few times.

Also, if you don't want to get out and remove the air cleaner and choke it to kill it during high idle, just put it in drive or reverse and shut it down. That is what I used to do till I got my issues figured out!
 

·
Registered
Joined
·
929 Posts
Discussion Starter #4
Thanks, once I wrote this I drove down to NAPA and grabbed some some carb cleaner right before they closed, il see if this works.
 

·
Deputy Director Region 18 Participating Member
Joined
·
6,292 Posts
try adjustinting the automatic chocke,it might be off when installed...

..the inner spring should fit inbetween #51...hope this help..:beer:
 

Attachments

·
Registered
Joined
·
2,782 Posts
Oh i got this one mine did the same thing. Brought me to 25 mph. You are idleing about 1800-2200 rpms. Trust me this happened to me too. Its not your cam. Your electric choke is acting up. Heres what you do. When the car is in high idle pop the hood and while its idleing high, adjust the screws for the electric choke until it idles down. Do t make it too low because that is the way the car warms up, so you dont want to eliminate the high idle but kick it down to you best estimate of around 1100 rpms. By doing this you will notice it warms up quicker too. Mine on a bad day idled at 3500 rpms for 18 minutes.... It was bad. But i got it all fixed. Try this before messing with the cam. If you need more help just ask

Brandon
 

·
Registered
Joined
·
603 Posts
Might be a couple of unrelated issues simultaneously.The dieseling one's odd,plus coupled with the high idle.Sounds like a linkage binding somewhere,maybe a timing issue also.A little spray lube on all the joints from the thottle pedal out,maybe.The continued clicking doesn't sound proper.Throttle return spring getting weak? Some grunkus get past the fuel filter and lodge inside the carb? Any codes thrown out from the ECM? Bad fuel causing the dieseling? Throw some Techron in the tank.The high idle cam's getting a signal from somewhere/something to engage. Run OK when you're driving it,outside of the 25mph autopilot? Check every hose and wiring junction under the hood while you're there.
 

·
Registered
Joined
·
929 Posts
Discussion Starter #9
Gonna go play with it more, I had it for a couple of minutes after spraying and playing with everything, then it just went back. The desieling is related to the high idle, becuase when i manually push the high idle cam down it shuts off fine, but once I give it some gas even with the motor off somehting still pushes the high idle cam back up.
 

·
Deputy Director Region 18 Participating Member
Joined
·
6,292 Posts
Gonna go play with it more, I had it for a couple of minutes after spraying and playing with everything, then it just went back. The desieling is related to the high idle, becuase when i manually push the high idle cam down it shuts off fine, but once I give it some gas even with the motor off somehting still pushes the high idle cam back up.
..the trobule I had was a seal/washer (60) that was sticking the shaft(57) on me,after a good lube,it work fine.. just a heads up..:dontknow::beer:

:beer:
 

Attachments

·
Registered
Joined
·
929 Posts
Discussion Starter #11
..the trobule I had was a seal/washer (60) that was sticking the shaft(57) on me,after a good lube,it work fine.. just a heads up..:dontknow::beer:

:beer:
Gilby, you may have been right on the money, I removed the choke pull off, and used the carb cleaner directly on the area closest to the carb, the area (60), and pushed and moved everything to ensure it was free. Went for a 15 mile ride stopping, checkng the idle by ear and shutting the cruck off, so far no problems. The real test will be how everything will react with a cold start in the morning!

Thanks alot everybody!:beer:
 
1 - 11 of 11 Posts
Top