El Camino Central Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 1978 el camino and the speedometer doesnt work. Ive disconnected the cable from the transmission and i can spin it by hand and it moves. That cable is good. under the hood on the driver side theres the cruise unit where the transmission cable goes in and theres another cable that goes inside and connects to the speedomter. Well when i turn the other cable the speedometer moves so im thinking its that unit but i dont know what its called :?: Could someone help any input would be helpful :evil: !!!!!!!!!!!!
 

·
Registered
Joined
·
46 Posts
replace the speedo gear in the transmission I would almost bet this is the problem for I have had it a few times. If you reed the mesage before yours that fixed his aswell.
 

·
Registered
Joined
·
2,921 Posts
CRUISE CONTROL MODULE/AMPLIFIER for a 1980 CHEVROLET TRUCK EL CAMINO.

OR

CRUISE CONTROL TRANSDUCER for a 1980 CHEVROLET TRUCK EL CAMINO WITH 3 TERMINALS


Item Part No. A-1 36-102
Core Value $20.00
Unit Price $59.99


AC-DELCO P/N 25030711

OR

CRUISE CONTROL SERVO for a 1980 CHEVROLET TRUCK EL CAMINO
Not Yet Available

Does this help? I got this from AutoZone's Web site.
 

·
Registered
Joined
·
23 Posts
the speedometer doesn't work in my 83 either, i took the gear out and it looks fine. but the cable is stuck in it and the color of the gear is natural i didn't think to count the teeth (duh) when i looked it up online that color only shows up under a 3.8 litre not a 5.0 vin says it came with the 5.0. does anyone know what color gear it should have in it ?
 
1 - 4 of 4 Posts
Top