El Camino Central Forum banner

1 - 10 of 10 Posts

·
Senior Member
Joined
·
823 Posts
sounds like a blown fuse... :dontknow:
 

·
Premium Member
Joined
·
5,899 Posts
Two totally different problems and solutions for the 2 problems. The horn circuit has nothing to do with the dimmer.
1. Unplug the green wire from the horn(s) and take a hot wire from the battery + to the terminal. Does the horn blow? If so you will need to go up under the dash and locate two things. The flat wiring coming down from the turn signal switch. Connect a test light to a power source and the probe to the black wire at the end of the connecter. Press the horn button. Does the light come on? If not the problem is in the horn button. If it does the problem is probably the horn relay located just above the e brake release.

2. When you pull on the turn signal lever to dim/brighten do you feel a resistance and hear a click? If not problem is in the column.
I TAKE BACK MY FIRST STATEMENT ABOUT BEING TOTALLY DIFFERENT. Is there play up and down side to side in the steering wheel?????????????? If so fixing that might fix both problems.
 

·
Registered
Joined
·
247 Posts
Discussion Starter #4
Two totally different problems and solutions for the 2 problems. The horn circuit has nothing to do with the dimmer.
1. Unplug the green wire from the horn(s) and take a hot wire from the battery + to the terminal. Does the horn blow? If so you will need to go up under the dash and locate two things. The flat wiring coming down from the turn signal switch. Connect a test light to a power source and the probe to the black wire at the end of the connecter. Press the horn button. Does the light come on? If not the problem is in the horn button. If it does the problem is probably the horn relay located just above the e brake release.

2. When you pull on the turn signal lever to dim/brighten do you feel a resistance and hear a click? If not problem is in the column.
I TAKE BACK MY FIRST STATEMENT ABOUT BEING TOTALLY DIFFERENT. Is there play up and down side to side in the steering wheel?????????????? If so fixing that might fix both problems.

no resistance or click in lever and yes a little bit of play in steering wheel, they both stopped working at different times
 

·
Premium Member
Joined
·
851 Posts
Agree w/464Elky....dimmer switch in column actuated by rod from signal lever sounds like not making contact. If your steering wheel (tilt?) is indeed loose, a tightening of the three bolts inside may solve your problem. Horn may also be a related issue.
 

·
Registered
Joined
·
247 Posts
Discussion Starter #6
Agree w/464Elky....dimmer switch in column actuated by rod from signal lever sounds like not making contact. If your steering wheel (tilt?) is indeed loose, a tightening of the three bolts inside may solve your problem. Horn may also be a related issue.

yes it is tilt, how would i tighten it ?
 

·
Registered
Joined
·
2,102 Posts
all good info above try one more thing,because the horn ground through the column, try grounding the black horn wire comeing from the ts harness(the car end) this will take the column and horn button out of the equation.if the horn blows its in the column.while you are under the dash ,look up at the dimmer switch,near where the brake pedal meets the column.is the actuator rod in place,if so push the lever and see if it is moveing.some times the column can get so loose the rod end will come out of the dimmer switch. i have to fix the very thing on my wifes camaro today
 
1 - 10 of 10 Posts
Top