El Camino Central Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
Working on my 86 today I notice my ignition condensor/capacitor is looking in bad shape. I have searched online for a replacement and have not seen any. Am I calling it something wrong? To replace, i would guess cutting and splicing the wire from the firewall will be necessary. With an HEI distributor is this even necessary?
127728
Any help would be appreciated
 

·
Registered
Joined
·
66 Posts
Discussion Starter #3
It plugs directly into the distributor. Could this be why my tach reads 3K at idle and pegs as soon as I touch the throttle?
 

·
Deputy Director, Region 3 PA (west)
Joined
·
1,571 Posts
Can't swear that it's causing your tach problem, but I would remove it, clean up the rust, make sure the clamp has good contact with the body, then clean the area where it attaches to the firewall so it has a good ground. Other than some labor, what have you got to lose?
I do know they're not easy to find.

Bill
 

·
Premium Member
Joined
·
728 Posts
I have one, I was actually looking at it yesterday thinking that I really need to go ahead remove it from the firewall. If I remember right the tach was the only thing in the dash that did work. Can't promise it will fix your problem but if you want to try send me a PM with an address and I'll mail it to you.

I would try Billy Jack's suggestion first, like he said, "Other than some labor, what have you got to loose?" And if that doesn't fix it let me know.

Joe
 

·
Registered
Joined
·
66 Posts
Discussion Starter #6
Appreciate the help. Car has been sitting for about 6 years and I am finally getting time to put it back on the road. Everything worked good when it was parked, but unfortunately time has taken its toll on her. I will try to clean it up and let you know if it fixes it. Thanks.
 

·
Registered
Joined
·
453 Posts
Does anyone know the specific name of this type of electronic part, such as resistor, condenser, etc., other than tach filter? If we did have more information about this component, we probably could find a suitable substitute part since these are getting harder and harder to find.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #9
I did see the one on mikes montes after @dmostated said it was a tach filter. $30 seemed a little high, but I guess if that's the only place you can get one it's better than nothing.
 

·
Registered
Joined
·
1,047 Posts
If it’s the tach filter, there are two GM numbers. 14062505 is ‘78-‘87 all with rallye gages’, and 14078957 is ‘84-87 w/cruise, tach signal’. I’m guessing the first number is the firewall mounted piece.
Patrick
 

·
Registered
Joined
·
66 Posts
Discussion Starter #12
I was wondering if that would not effect it or make it worse. Guess it's worth a shot. Thanks
 
1 - 12 of 12 Posts
Top