El Camino Central Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
339 Posts
Discussion Starter #1
I was cleaning my choke plate and i broke a hose off of the little ac thing inside the airfilter.. theres 2 hoses going into this little thing on the air filter that says ac and i figured the one hose didnt matter because it went to the polution pump thats broken.. anyways now that the hose is not hooked up as im driving my check engine light is studdering on and off and as it comes on and off and feel my car studder as well like slow down.. idk if i messed it up when i was cleaning it or should i replace the little hose?
 

·
Registered
Joined
·
532 Posts
i think i would check for vacuum leaks first, then chase down and make sure everything else is plugged up good, is this a functional ccc carb? are these vacuum line sized hoses, if so maybe that little ac thing is a temp controlled vacuum switch and at operating temp its open. need to know more about what you are dealing with. if it is just the hose that is broken vacuum hose(or smog size hose(5.8) )is cheap replace it and see if that cures your problem.
 

·
Registered
Joined
·
339 Posts
Discussion Starter #3
i think i would check for vacuum leaks first, then chase down and make sure everything else is plugged up good, is this a functional ccc carb? are these vacuum line sized hoses, if so maybe that little ac thing is a temp controlled vacuum switch and at operating temp its open. need to know more about what you are dealing with. if it is just the hose that is broken vacuum hose(or smog size hose(5.8) )is cheap replace it and see if that cures your problem.

Thanks for replying back.. it must be that hose because driving to work and coming back i didnt use ac at all and i didnt have any problems.. now i was gonna just pick up a thin rubber hose from pepboys and zip tie it to both ends.. now the only problem is there two hoses both have the same size end tips but i dont know which one goes to what.. i guess when i took it off i didnt realize.. the little ac thing on the air filter has two little spouts to attach it with.. both the same size but one has a bigger hole and one has the smaller hole ?!
 

·
Premium Member
Joined
·
846 Posts
The AC thing on the air filter.........you said you didn't use the ac at all when driving.... are you sure the broken piece in question isn't a thermal switch manufactured by AC Delco and thats the brand?
 

·
Registered
Joined
·
339 Posts
Discussion Starter #6
The AC thing on the air filter.........you said you didn't use the ac at all when driving.... are you sure the broken piece in question isn't a thermal switch manufactured by AC Delco and thats the brand?
i cant be sure if thats the brand right now but it was on my old air filter and i replaced it on my new air filter it was a little plastic mechanism
 

·
Supporting Member
Joined
·
4,477 Posts
The "AC" thing is in fact made by AC Delco, and is a vacuum switch used to close the snorkel on the air filter, allowing the air filter to draw warm air from the Exhauyst Header area. Intended to make cold starts and warm up easier, and at the same time probably helps emissions a little while cold. If it is not plugged in, it will not affect anything except cold starts, and even then it's got to be pretty cold to really show up.

I believe the problem is that the vacuum hoses are not attached ( or plugged). This creates a vacuum leak, and that is what is causing your car to run rough. Track down the mounting points for those two hoses, and plug them ( or replace the hoses).
 

·
Registered
Joined
·
127 Posts
I believe the problem is that the vacuum hoses are not attached ( or plugged). This creates a vacuum leak, and that is what is causing your car to run rough. Track down the mounting points for those two hoses, and plug them ( or replace the hoses).

x2
 

·
Registered
Joined
·
1,810 Posts
While your there, buy enough to replace all the vacuum hoses (one at a time). Your car will thank you.
 

·
Registered
Joined
·
339 Posts
Discussion Starter #10
While your there, buy enough to replace all the vacuum hoses (one at a time). Your car will thank you.
vacuum hoses? just replace the one hose not plugged in? i didnt have this problem until i touched those two hoses it what im saying.. and ive been driving the car for the past 2 days with no air or heat on and i havent had the problem? if you guys still think its the vacuum hoses.. how many are they and where are they located? thank very much!
 

·
Registered
Joined
·
339 Posts
Discussion Starter #11
vacuum hoses? just replace the one hose not plugged in? i didnt have this problem until i touched those two hoses it what im saying.. and ive been driving the car for the past 2 days with no air or heat on and i havent had the problem? if you guys still think its the vacuum hoses.. how many are they and where are they located? thank very much!
by the way what hose attaches to the spout with the big hole and which hose attaches to the spout with the little hole? the piece that broke off is hard plastic with a rubber nozel that attaches.. while the other hose is a rubber hose.
 

·
Premium Member
Joined
·
2,055 Posts
the hose has a vacum source - you may not need the actuator, but you will need the vacum. just trace it back to the souce and put a cap over that source. it will be either off the manifold or off the carb.

while you are going about that, replace ALL your vacum hoses, and there are many in an '85, you may even have some check valves that need replaced as well - check the one behind the carb, that one finds it's way right down on the manifold, where it will get hot and melt enough to create a hole; and another vacum leak. getting all the vacum back will make your engine run better.
 

·
Registered
Joined
·
339 Posts
Discussion Starter #13 (Edited)
the hose has a vacuum source - you may not need the actuator, but you will need the vacuum. just trace it back to the souce and put a cap over that source. it will be either off the manifold or off the carb.

while you are going about that, replace ALL your vacuum hoses, and there are many in an '85, you may even have some check valves that need replaced as well - check the one behind the carb, that one finds it's way right down on the manifold, where it will get hot and melt enough to create a hole; and another vacuum leak. getting all the vacuum back will make your engine run better.
I really appreciate all the replys.. I havent done anything since the problem.. and it happened again driving to the gym check engine comes on it feels like it wasnt giving it enough gas for a second or two so i pulled over and shut the car off and the engine sputters a little after.. so im on my way to pepboys im gonna take this piece that broke off and see if i can get a little rubber hose that will fit on both ends and try to connect it back and zip tie it on.. im not sure what a vacuum hose is but im guessing its a rubber hose so i will look at the one in the back of the carb and see if its cracked but wont be sure if i would know exactly how to replace it.. hopefully this works out :/ being 21 not getting paid to much and have a beautiful car with constant engine parts is one big headache unfortunate :( one again appreciate all the help

Btw there is a picture of the hose that broke off..
 

Attachments

·
Registered
Joined
·
339 Posts
Discussion Starter #14
I really appreciate all the replys.. I havent done anything since the problem.. and it happened again driving to the gym check engine comes on it feels like it wasnt giving it enough gas for a second or two so i pulled over and shut the car off and the engine sputters a little after.. so im on my way to pepboys im gonna take this piece that broke off and see if i can get a little rubber hose that will fit on both ends and try to connect it back and zip tie it on.. im not sure what a vacuum hose is but im guessing its a rubber hose so i will look at the one in the back of the carb and see if its cracked but wont be sure if i would know exactly how to replace it.. hopefully this works out :/ being 21 not getting paid to much and have a beautiful car with constant engine parts is one big headache unfortunate :( one again appreciate all the help

Btw there is a picture of the hose that broke off..
OK so i have a few pictures i took of the hoses and what not.. the first picture is where the hose snaped so i picked up some vaccum tubing im gonna pop on each and and re connect it.. theres another plastic tube the same size looks like it snaped but i dont know where it goes too..
the other pictures are a few randoms of the hoses and what not..
 

Attachments

·
Registered
Joined
·
339 Posts
Discussion Starter #15
OK so i have a few pictures i took of the hoses and what not.. the first picture is where the hose snaped so i picked up some vaccum tubing im gonna pop on each and and re connect it.. theres another plastic tube the same size looks like it snaped but i dont know where it goes too..
the other pictures are a few randoms of the hoses and what not..

hey btw i replaced the line and found about 2 or 3 more hoses that looked to be the same size so i replaced them as well.
 
1 - 15 of 15 Posts
Top