El Camino Central Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
got around to installing a new master cylinder and booster with proportioning valve. Still didn't have decent brakes (all pads and shoes are newer and adjusted) Spent a good amount of time bleeding and flushing the system and was successful there. Since I have a big cam and my vacuum is around 6, I purchased a Leeds vacuum pump and installed it today. That should have solved the problem. It was a clean install and the cut it/out works good on the pump. Tested the booster check valve, and it works fine. New line, no holes, works good. When hooked up to the booster, the pump will not shut off and the booster won't allow a vacuum. Rats, it's new so it should work and hold a vacuum. My plan now, is to remove the assist pod, hook it up to vacuum and test it out of the vehicle system and try a new one. Dang, not sure what else it could be at this point. Stumped.

here's the new unit I put in:

https://www.elcaminostore.com/el-camino-master-cylinder-with-booster-for-disc-brake-conversion-1964-1966.html
 

·
Registered
Joined
·
1,318 Posts
Try changing the pedal ratio to the manual ratio 6:1. There should be another hole were the linkage connects to the pedal. Try using that hole.. This and switching to a 1" bore master cyl worked for me. My old 462 Pontiac had a 308/320 cam...
 

·
Registered
Joined
·
11,853 Posts
is the vacuum pump T in between the check valve and the booster ??
check valve flow arrow pointing to the carb ??
.
make sure the pedal is releasing, all the way up,,
and the pushrod is not too long.. they need 1/16" to 1/8" play..
.
not the first time i'v heard of a bad bran-new booster..
.
:texas:
 

·
ZERO MPG
Joined
·
15,362 Posts
Rear brake hose may be collapsed it happens all the time. Make sure when you bench bleed the master cylinder you got all the air out. Make sure you got the correct master or the pedal ratio will cause problems.:cali:

I would start with bench bleeding first if everything is right.

Picture is for reference only!
 

Attachments

·
Registered
Joined
·
42 Posts
Discussion Starter #6
Thanks for the help and replies. I took the booster off and bench tested it with the vacuum pump. It will not hold air, and the check valve is working. I ordered a new system through Summit racing that fits my disk/drum setup and we'll see if it fits. I will test the booster BEFORE it goes in the car this time~! What a PITA. Well, I have a couple days free so I guess i'll start working on another el camino project until the booster comes in. Thanks again.
 
1 - 6 of 6 Posts
Top