El Camino Central Forum banner
1 - 9 of 9 Posts

· Regional Director, Region 5
Joined
·
1,894 Posts
Discussion Starter · #1 ·
I finally got around to putting a new engine in my SS. The rebuilt bottom is 40 over with a Liberty kit & Speed Pro flat pistons. I got new 64cc alumium heads that give me 9.8 to 1 com. I use a Comp cam xe268. I have a Edelbrock proformer intake & 1406 carb, a new HEI dist. & MSD-6a . I have around 250 miles on her so far & I love it.
 

· Registered
Joined
·
3,717 Posts
Welcome From Texas!!:texas: Since its been 4 years since yuor last post, do you feel like a noob? Thats crazy man. I didnt recognize your handle so i looked it up. I joined around the same time you fell off, so welcome back. Congrats on the new engine as well. Hope it lasts a good long time.
 

· Deputy Director Region 8
Joined
·
2,942 Posts
Nice Tommy!!! Did you put the motor in that orange Camino?? It looks like you have the stripes on the hood,, if so can you get a pic of them?? I am going to start my 80 Camino project and I want to paint it a Gold color wiith charcole stripes maybe,,, Matty man
 

· Regional Director, Region 5
Joined
·
1,894 Posts
Discussion Starter · #6 ·
Thanks, My SS is still Hugger Orange. I make a garage pic. The military has keep me pretty busy. I hope to be home for awhile. I hope to retire one of these days.
 

· Regional Director, Region 5
Joined
·
1,894 Posts
Discussion Starter · #8 ·
I am also running headers to turbo mufflers. Can anyone give a guess to the Hp rating this motor is putting out? Our guess is upper 300s.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top