El Camino Central Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
installed a cd player...no issues...went out for a ride when i was finished hit my turn signal and it blinked once and stopped..i just replaced the flasher relay about a week ago so dont think thats it....any suggestions?
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #5 ·
cd player has memory wire and power wire....tapped into the cigarette lighter for memory....already tried 4 ways they flash and all bulbs are good....i pulled all the fuses and they looked fine to me...not sure which one is for what tho...dont have the fuse diagram
 

·
Registered
Joined
·
2,102 Posts
did you change the hazard and turn signal flashers ?try the hazards to test the wireing and bulbs.they use the same wires and filaments in the bulb as the turn signals and use a different power source.if they work try switching the flashers to test the other one. check your fuses
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #7 ·
swapped out hazard and turn signal relay..hazards still work...all the fuses are still goood
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #8 ·
i guess maybe the switch went bad??? its been sitting for a long time and ive started driving it daily so im expecting there to be some issues
 

·
Registered
Joined
·
2,102 Posts
check to see if you have power at the turn signal switch plug.take out the hazard flasher so not to confuse its power supply for the ts. find the hot wire for the ts if not hot look between ti and the fuse box,if it has power it is in the ts switch
 

·
Registered
Joined
·
12,538 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #11 ·
hmmmm....power everywhere there should be...headed out to get a switch i guess....thanks for suggestions and the diagrams guys
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #12 ·
...well i just saved myself some money....bad connecting block on the blue wire from the fuse block to the flasher relay...chopped and spliced working fine now
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #13 ·
does fixing one thing always lead to fixing another???...chasing a ground issue down now.....*sigh*:let_it_all_out:
 

·
Acting Director, Region 13
Joined
·
2,048 Posts
does fixing one thing always lead to fixing another???...chasing a ground issue down now.....*sigh*:let_it_all_out:
It does see that way sometimes. Just keep in mind the age of it, and remember repairs will be necessary.

Tim
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #16 ·
headlights blinking with turn signals...tested it out didnt have any ground on anywhere in the front...im guessing everything must have been grounded through the old tape deck...it was grounded at the gas pedal and i used the ground from the factory wiring harness on the new cd player....not sure why they didnt use it to begin with but i guess when i took the ground from the gas pedal i lost it everywhere.....got everything working with a quick fix but i guess tomo im gonna be doing some wiring
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #17 ·
ground wire coming from the battery to the body was broken.....everything works now...i think its fixed...maybe
 
1 - 18 of 18 Posts
Top