El Camino Central Forum banner
1 - 7 of 7 Posts

· Premium Member
Joined
·
12,604 Posts
Discussion Starter · #1 ·
I put the new ignition switch in my column and nothing changed. The key is to far forward, it won't turn any further to start and will not come back far enough to remove key. Upon further inspection I see the rod has teeth on it and so does the little gear with the ears that the ignition turns. This is a floor shift car so it also has a little lever that you push down on for the key to come back far enough to remove. The little lever lifts the rod up that goes down the column. I THINK what happened is someone forced the key and it jumped teeth. I don't see any striped. Anyone ever see that happen? Anyways it looks like I'm going to have to remove the whole column to tear it apart to see what happened. I would like to know if anyone has a link to disassembly pics of it. It's on the 80 (Whole shot) true to its name!!!! :let_it_all_out:)
Ideas?
Thanks ahead of time!!!
Donny
 

· Registered
Joined
·
2,425 Posts
I'll bring my tools, and fix it on the 8th after everyone is tired of me.:beer:, but someone has to hold the light.
Someone was probably in there and got the gear you speak of out of time by 1 tooth.:texas::beer:
 

· Premium Member
Joined
·
12,604 Posts
Discussion Starter · #7 ·
I forgot who sent the PM wanting to trade for my steering column, resend on our previous message and we'll talk. I don't have time to jack with this!!:let_it_all_out:
Donny
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top