El Camino Central Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hello to everyone! My first topic here.Found two ported vacuum valves broken.One of them(black)was glued and fallen apart in my hand,Second(blue/violet?)one, similar.Trying to find the right ones , but need a part numbers.In case of black one ,there is additional problem.Everything what I can find on ebay or amazon and it fits my car(5.0 ) ,looks different.First of all the screw is 3/8.In mine this is 1/2 ?? Also the shape is different.
they are located in front of engine.Black one at the end of coolant hose from radiator,second a bit to left.Thanks for any help.
Regards
Janusz
 

·
Registered
Joined
·
12,533 Posts
welcome Mike
what year
pics would help

the one in the coolant hose is probly the Heater Control Valve..
the in-line ones look better and get it out of the way too..

are the other 2 on the water outlet ??
 

·
Registered
Joined
·
21 Posts
Discussion Starter #5
This is 1979,305 ci.Will makle a pictures today morning.Its 2 am here:).
The black one - two vertical ports.It is not in coolant hose but in manifold front of hose.Just between hose and carb.Found it as AC Delco 212-618 EGR.The other one blue is AC Delco 212-595(?)
Rgds
 

·
Registered
Joined
·
12,533 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #9
Thank You a lot.Was looking for Them on Rockauto ,but didnt expect Them in "electrical switch and relay");
 

·
Registered
Joined
·
21 Posts
Discussion Starter #10
Finally got them here in two days !!.Black was Ok,but mistakenly ordered blue one instead of purple.Looks, everything works fine.Cant find anywhere the difference between blue and purple one.Hope this is not a big issue.Anyone knows ?
 

·
Registered
Joined
·
12,533 Posts
what does the blue switch connect to ??
vacuum comes from the carb.. where does the other side go to ??

25*F is not that much difference.. and that's probably +/- 5*
you will probably be ok..
 

·
Registered
Joined
·
21 Posts
Discussion Starter #16
cant say now where does it go to.Replaced it because one of the ports was broken.In meantime ordered new one on Rockauto.40 bucks and will arrive beginning of next week:)So far the blue one makes no changes , as You say ,but preffer to start from stock specs before making any adjustment or tuning.Today is three weeks I'm on the road.
 
1 - 16 of 16 Posts
Top