El Camino Central Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
281 Posts
Discussion Starter #1
Sons ps hose blew out, replaced it, now its making funny whining noises. Did he fry pump, or is fluid just contaminated?. Been trying to flush, but fluid looks like chocolate milk after starting, like oil and water mixed. There was Lucas stop leak in it before. It's a 64, 283, stock. Please advise, I need my truck back!
 

·
Banned
Joined
·
5,787 Posts
depends on how long it was run without fluid, it could have air in it,try jacking it up in the front and turning wheels lock to lock see if it helps with the noise, :beer:maybe work the air out of lines
 

·
Registered
Joined
·
11,510 Posts
sounds like air in the ps lines/system. here's the old school cure, that even dealers used, to fix this.

Turn the wheel all the way to the left, turn off the engine and let it sit overnight this way. The old steering box-type systems are designed to allow the air to bleed out of the system this way. this works on all american vehicles with steering boxes and ps.

:beer:
 

·
Registered
Joined
·
281 Posts
Discussion Starter #4
Thx, guys. I will try it and update, thx again
 

·
Registered
Joined
·
281 Posts
Discussion Starter #5
filled with fluid, started car on jack stands, let it warm up. worked steering a few times back/forth, let it run a while, repeat. Seemed to work. took on test drive, no noise, very responsive. When i got back, turned wheel full left and let sit overnight, just for s/g. Kid says it's great, no noise, drives well. I actually think it was fine from just sitting overnight. The fluid looks fine, IMHO, I think the appearance of the fluid was from the small amount of lucas stop leak, ps fluid, and air in system creating a blender effect until all air was blead out........looked like a mudslide! Thanks for the help guys, you're the best! Now, on to next project, brake booster install on 66! :You_Rock:
 
1 - 5 of 5 Posts
Top