El Camino Central Forum banner
61 - 80 of 82 Posts

·
Registered
Joined
·
346 Posts
Discussion Starter · #63 ·
@Beige80 You two are really moving along. She’ll be all done in no time. Texas road trip, ehh?
Thanks bro. We have busted our butts going over all the mechanical things. We had the new tires installed yesterday and took it out for the first time while legal😎 We took it out in the freeway and it cruises well. Stay tuned for a new update soon regarding the motor🤔
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #64 ·
Today is the day we been working for. We took ol Rats Nest our for a nice cruise. It runs good, stops good, rides good. All the hard work was worth it!!!! We still have a few annoying issues to sort out but overall we are very pleased with the outcome. Look for a update regarding the new motor and gear swap coming soon🏁😎
 

Attachments

·
Registered
Joined
·
346 Posts
Discussion Starter · #65 ·
New update....
We spent alot of cash getting the carburetor rebuilt but it has a hesitation just off idle that we can’t get rid of. We have tried several things but so far no dice. Any tips are welcome. Other than that we have been enjoying cruising around. We are going to our first car show in 2 weeks and can’t wait 😊
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #66 ·
New Update...
The last 2 weeks we have made 2 car shows. We wound up tossing the Mtman carb in favor of the 30 yr old carb that came off the blown up motor. A can of carb cleaner and some compressed air and it runs great... too bad I wasted $275
We picked up a engine stand for $40 and will soon start tearing down the 350 for a full rebuild. We also primed and painted the driver side fender flat black, looks good for rattle can. Here is a few pictures
Cheers .. Lumpy 2.0 coming soon
 

Attachments

·
Registered
Joined
·
346 Posts
Discussion Starter · #67 ·
Carburetor madness😎
We came across this 750cfm vacuum secondary carburetor and grabbed it up. Fresh rebuild with the paperwork. Has had the rear metering block conversion to a jetted metering black like on the double pumpers😎. Now we will start accumulating parts for the lower end. Any suggestions on cubic inch is welcome. Cheers 😎
 

Attachments

·
Registered
Joined
·
346 Posts
Discussion Starter · #68 ·
Today was a great day. A road trip to the Dallas/Ft.Worth area netted some much needed parts. Thanks to DDD and 87ls5.3. It was great seeing y’all. We wrapped up the day at Summit Racing in Arlington which netted a set of KYB front shocks and misc stuff. Pics will follow.
Hammer Down Cuz...🏁😎
 

Attachments

·
Registered
Joined
·
346 Posts
Discussion Starter · #69 ·
I'm back.
Update...
We lost the motor in our elcamino on the way home from a car show about 6 weeks ago..cam went flat and sent metal all thru the motor. 😲 We have a spare motor and we are gathering parts for it. We have a set of World Product heads a lunati cam and Weiand single plane intake and a 750 cfm carb...stay tuned😎
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #70 ·
MOTOR MAGIC
Our motor is finally at the machine shop getting some much needed love. Specs are🤔😎
Stay tuned🏁
 

·
Senior Member Participating Member
Joined
·
944 Posts
X2 Beige 80! 😮
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #77 ·
Our gas gauge has never worked correctly especially with the lights on, it would go to empty. I checked grounds and wires at the tank and the rear harness to no avail. It was the ribbon on the instrument cluster was bad and was shorting out. I pulled the cluster out of a parts car that Minoridertim and I had. Took 2 and made 1. Now all dash lights and gas gauge works as it should. I’ll worry about painting it to match sometime down the road. Yay me 🏁👍😎
 

Attachments

·
Registered
Joined
·
2 Posts
Speaking of gas gauges, my 85 G body has a weird issue with the sender. It reads half tank in the full position, and empty at the bottom. The gauge reads 0 ohms at empty and 200 at the top, but the gauge doesn't register that. I know a 0-90 is appropriate, but even with 200 ohms I can't get a full reading.

I am doing an in tank fuel pump conversion so I need a separate sender and pump assembly. Any ideas? Thanks!!
 

·
Deputy Regional Director, Region 13
Joined
·
5,374 Posts
Speaking of gas gauges, my 85 G body has a weird issue with the sender. It reads half tank in the full position, and empty at the bottom. The gauge reads 0 ohms at empty and 200 at the top, but the gauge doesn't register that. I know a 0-90 is appropriate, but even with 200 ohms I can't get a full reading.

I am doing an in tank fuel pump conversion so I need a separate sender and pump assembly. Any ideas? Thanks!!
have you pulled your gauge cluster apart to check grounds?

 
61 - 80 of 82 Posts
Top