El Camino Central Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I just bought an 87 model, speedometer is not working. The cable seems to be okay, I took cable loose from transmisson and hooked up a drill to it and it worked. So i figured it was the gear that goes inside tranny. I jacked up rearened with the cable unhooked and the wife put it in gear so i could watch to see if it would turn. It seemed to be turning okay until i put my finger on it and it stopped with just little force on it. You let off finger and it starts turning again. Does this mean i need another gear dilly or what ever it is cslled. If so can you get it at parts sotre? Thanks for any input.
 

·
Registered
Joined
·
2,921 Posts
You have two gears in the back transmission housing. A drive and a driven gear. That is what they are called. It could be the drive gear, larger gear inside the housing and it could just be the driven gear, the smaller one you had your finger on.

Remove the driven and look at it. If the teeth are missing or worn down really badly then I'd go ahead and check out the Drive gear also. The Cruise Module is a POS and from time to time can lock up or bind when they go bad or start to go bad creating more friction and causing the gears to wear.

You can generally pick those up at a transmission place or at the dealers place. They will ask what the teeth count is or the colors or both. Get the wrong ones and the speedo is off.

I'd check the cruise master on the fender well also see if it is bad or just replace it.

Just my advice.
 
1 - 2 of 2 Posts
Top