El Camino Central Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
First off hi guys new to the forums. Im currently having issues with my 69 El Camino.
Im running a 350 with TH 350 tranny. The car is currently having issues shifting from 2nd gear to 3rd. First off I have changed the modulator with no effect even after adjustments. Here are the symptoms. 1-->2 shifts perfectly at about 15 mph the shift is firm. Shift form 2--->3 doesnt happen. I have run to 70+ MPH with no shift happening. At 40 or 50 MPH if I slip into neutral and then back to drive quickly car will shift cleanly to 3rd. A couple times at near WOT if I let off the gas quickly then acclerate again it will shift to 3rd again a nnice solid shift with no slip. I changed fluid and filter back and while it was apart removed the valve body and all pistons moved freely and everything was clean. There where no metal shaving in oil pan or filter. There was a slight black coating on bottom of pan otherwise teh insides where realy clean. Has anyone run into similar problems or have any suggestions where to go next? Could this be a governor problem?
Thanks in advance for all help.
 

·
Registered
Joined
·
463 Posts
have you checked the downkick cable for adjustment or binding? after that i would check the governor
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I have checked the down kick cable. I have checked all vacum lines they all apear to be good and holding vacum. Also it is hooked to manifold vacum. Will check govenor today and get back. What should i be looking for with the govenor?
 

·
Registered
Joined
·
463 Posts
pull it out, hold it by the gear with the weights pointed to the ground, squeeze the weights together and make sure the valve inside is functioning. you can see it move thru the ports. then check the bore in the trans case to see if there is any excessive wear. somthing i failed to mention earlier. did you check the modulator valve to see if it was free? It could be sticking in the bore. pull it out and clean it real well. then run it in and out a few times making sure there is no stick at all.
 

·
Premium Member
Joined
·
5,936 Posts
I would think if it was the modulator or governor the one/two shift would also be late. I'm thinking 2/3 shift valve.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #9
Ok we decided to just buy a new th 350. it was gonna cost more replacing parts than it would for a new one. :( So know we installed teh new transmission and the car goes into park but doesnt lock the tires all the other gears work perfectly to is there and adjustment i need to do to fix this?
 

·
Registered
Joined
·
1,663 Posts
Check the shift linkage for proper adjustment and if it is correct contact where you got the tranny as they prefer to make any internal adjustments doing otherwise will probably void any warranty.
 

·
Venerated Member RIP
Joined
·
4,461 Posts
Check the shift linkage for proper adjustment and if it is correct contact where you got the tranny as they prefer to make any internal adjustments doing otherwise will probably void any warranty.
x2 Let the shop that built the trans make ALL adjustments on the trans due to warranty. You can adjust the linkage tho.
 
1 - 11 of 11 Posts
Top