El Camino Central Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,348 Posts
Discussion Starter #1
Since my experience with the cessation of noise coming from the engine compartment of my El Camino, I have spent almost 2 weeks getting it running again.

First, I changed the gas filter. Yes, it was dirty, and I'd give good odds that's why it quit running and had to be towed. After I changed it, it ran enough to get it around to the back of the house and into the garage. But it didn't run well.

So, I've removed the AIR pump and injections lines. One plug broke off, so I spent several days trying to get it out, and then drilling out the tube and tapping the plug for a bolt to put in it.

I changed the old electronic non-advancing distributor to a vacuum advance distributor. New plug wires. New spark plugs.

Started it up, and it was obviously retarded, so I pulled the distributor back out and moved it forward one tooth. Set the initial advance to 12 degrees.

Started it up again, and it sounds better than the day I bought it. Feels like it now has some "snap" to it.

Now I need to take off the manifold and put on my new Edelbrock Performer. New belts and hoses. Get rid of the catalytic converter, somehow.
 

·
Registered
Joined
·
1,348 Posts
Discussion Starter #4
It already has a non-electronic QJ on it.

I'm tempted to put on an Edelbrock, which I've had good luck with, but the one on my T bucket gets 15 mpg and it weighs 1500 lbs less than the El Camino, so that may not be an economical idea.
 

·
Registered
Joined
·
2,782 Posts
Gee, my Grandpas t-bucket has a Holley 700 cfm on a 350/ powerglide/ 3.73 LSD and gets 6 mpg...
 

·
Registered
Joined
·
1,348 Posts
Discussion Starter #6
I had a Holley when I first finished this build. I messed with it for two months, trying to get it to run right. Went and bought the Edelbrock, started it up, and drove it away with nary a problem. I've made one change to it since then, to lean up the idle a little, if I recall correctly. It got some dirt in it one time, and it was a 10-minute fix without replacing a single gasket (no gaskets in the Edelbrock below the top of the gas level in the float bowl).
 
1 - 6 of 6 Posts
Top