El Camino Central Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
I am trying to figure out what kind of sensor/switch is mounted in the thermostat housing on my 350 4 bl. it has a green lead wire that disapears into a wiring harness. I also have a green lead to attaches to the temp sensor at the front of the left head. Does anyone have any guesses what this sensor may be doing there? :?
 

·
Registered
Joined
·
1,113 Posts
I am not sure if your 77 is the same as my 86 Caballero, but from what I can tell from your question, they appear to be alike. The sensor on the thermostat housing goes to my ECM. The ECM uses this input to adjust emission controls. The sensor at the front of the driver side head is used to run my temp gauge (I don't have the temp idiot light). Hope this helps.
 

·
Moderator
Joined
·
1,867 Posts
The one on the side of the head is the water temp sensor for your gauge or idiot light.
 

·
Registered
Joined
·
81 Posts
Discussion Starter #4
I am told that in 77 there were no ECM's on elkies. I guess I am going to have to try and trace down exactly where the lead to that thermostat housing sensor goes. I have my oil switch by the distributor, my water switch (soon to be gauge sensor) on the front left head, and then this unknown sensor at the thermostat.. It may be that the previous owner did some modifications for some reason.. Thanks gents
 

·
Moderator
Joined
·
1,867 Posts
Deffinently no ECM on a 4th gen. Sounds like something someone added at one time.
 
1 - 5 of 5 Posts
Top