El Camino Central Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,502 Posts
Discussion Starter #1
This is Embarrassing...
I removed the hood from my 84 to drop in the 350 to replace the original V6...I pulled all the hardware to clean & paint etc....Repainted underside of the hod, glassed in a scoop...all the fun stuff :nanawrench:But now I can't get it to fit???
Never had this happen...It will not drop down at the nose or line up side to side? I spent hours screwing with it...Anyone have a trick up thier sleve? :dontknow:
 

·
Premium Member
Joined
·
12,547 Posts
No trick I know just adjust a little here then there until it's right. Did you put the henge and spring bolts back in the right spot. I say the because once I removed one and put the front spring mounts in the wrong place and it took a little while to see what I had done wrong.
Donny
 

·
Registered
Joined
·
1,502 Posts
Discussion Starter #3
Found the problem!

I just could not get the Right side to close like the drivers side...Just did not make sense...I have never had this much trouble with a hood!

I put on my detective hat...Pulled the spring brackets and found the one on the right was about twice as strong as the left??? Looked on the shelf in my garage, and there was another one!?!! Checked it and the tension matched my drivers side unit...Replaced both of them and Slam... I got it right this time :nanawrench:
Both spring brackets look the same but this other one was for a larger hood...Time to sort out all the spare parts....
 
1 - 5 of 5 Posts
Top