El Camino Central Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
i have a 1981 and my blinkers do not work. i have changed the switch and the flasher fuses and they still dont work, my hazards however do work. what is my problem?
 

·
Registered
Joined
·
11,510 Posts
i have a 1981 and my blinkers do not work. i have changed the switch and the flasher fuses and they still dont work, my hazards however do work. what is my problem?
flasher can for the turn signals. costs about $4

:poke:
 

·
Deputy Director, Region 1
Joined
·
2,566 Posts
Check all the bulbs including the side marker lights. With the parking and headlights off, try the signals on one side. The tail lamp and front signal should light. If one or both don't check/change the bulbs. Then try the other side. Now try with the lights on. When the signal on either side is turned on the side marker lamps should go out. With lights on the park lamp and tail lamps alternately flash with the side markers. If nothing is happening check for power at the fuse box where the signal flasher plugs in. If that's OK check each bulb socket for 12 volts. Then check the grounds for continuity. If none of that helps check the long black plastic connector on the right side of the lower steering column. Make sure it's connected well and there are no loose wires. This is the harness from the signal switch inside the steering column.
 

·
Deputy Director, Region 1
Joined
·
2,566 Posts
Yes hazards and signals share the same filaments in each bulb. Are those working as described above in the test with lights on? Each bulb lights when it should?
 

·
Deputy Director, Region 1
Joined
·
2,566 Posts
Ok you need to be a bit clearer. What works? Hazards? Every bulb?
 

·
Deputy Director Region 6
Joined
·
8,864 Posts
I had a NEW turn signal flasher go bad after a few weeks ???
 

·
Registered
Joined
·
10 Posts
Discussion Starter #16
i tried different ones so it isnt that, im thinking its the part of the fuse box were i plug in the fuse. i need test test the connection
 

·
Registered
Joined
·
85 Posts
DO WHAT JMP DADDY WROTE YOU KNOW THAT THE FLASHER WORKS --IF THEY (turn lites) STILL DON'T WORK --GROUND or SWITCH
 

·
Registered
Joined
·
2,102 Posts
the turn and hazards use different flashers .did you change both or the right one ? if the hazards work then the wireing is good as the turn and brake lights use the same wires to the rear. do your indicators come on in the dash when you turn on the signals ? if so you have a bulb out somewhere or a bad flasher.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #20
its not the flasher, i think its the part of the fuse box were the turn signal flasher goes that isnt working. i need to test if the part is getting power
 
1 - 20 of 22 Posts
Top