El Camino Central Forum banner

4161 - 4180 of 4214 Posts

·
Registered
Joined
·
7,579 Posts
I haven't driven the Elk since I started wiring the cruise control in. This is a used unit that the gray wire going to the control panel had a section cut out of it. The person I bought from gave me a wire to reconnect into it. I forgot to connect it. So I finally got it connected. I hope that the weather doesn't go nuts so I can try it out.
 

·
Registered
Joined
·
42 Posts
Removed the drivers side header, broke 2 spark plugs, welded in a bung for an AFR gauge, wired it up and waiting for an A pillar gauge pod. I need to start tuning the carb...the plugs show it's running pretty rich.
 

·
Registered
Joined
·
7,579 Posts
I started up the 78 today, it took a while turning over to get the gas to the carburetor, since it's been 3 weeks since I last started it. No problems with the battery and it ran very good.
 

·
Registered
Joined
·
2 Posts
Probably not what you want to hear but... After 14 years of putting money into my 1966 El Camino to make it FUN and pleasureable to drive, today was the first time I was able to stomp it and spin the tires in the mall parking lot. Not that far, not a burn out. (It was just us seniors getting ready to mall walk.) Just to prove to myself it was finally able to do that once. Oh I am retired, VERY, and since the roads were clean I drove my El Camino everyday this week.
 

·
Registered
Joined
·
42 Posts
Put in a new HEI cap, rotor and module. found a bad spark plug in #1 cylinder (wasn't getting full spark). Swapped that one out , timed to 14* initial. Changed the Idle Jets to size 80, Adjusted the Quick Fuel Tech carb idle screws to get a 14 AFR. Going to take it out for a run tomorrow and see if I can beat my last 1/4 mile run, where I smoked the tires for 30' and missed a shift. Time to beat: 15.2 Should be easy. Using the phone app: GPS Race Timer.
 

·
Registered
Joined
·
7 Posts
I changed the differential fluid in the 86’ elco, new fuel filter , fixed the review mirror, changed the oil , checked/adjusted the timing.
 

·
Registered
Joined
·
391 Posts
Took the heater blower out of the 77, shot some lube onto the bearing through the vent hole on the side. Bench tested it and the squealing was gone. Vacuumed it out, cleaned it up and reinstalled. It wobbles a tad when turning so it will probably need replacing, but it is good for now. I only had to remove the vacuum canister to clearance, so pretty straightforward.
127439
 

·
Registered
Joined
·
245 Posts
put my elcamino's battery on charge. definitely going to have to figure out what is draining the battery this summer. it isn't going flat dead yet but low enough to not start. need to get it sorted out before i install the new battery i got for it.
 
4161 - 4180 of 4214 Posts
Top