El Camino Central Forum banner

4221 - 4240 of 4262 Posts

·
Registered
Joined
·
43 Posts
Just finished replacing the heater fan with a junkyard find (tested it before pulling the old one out). It's working good and runs quietly unlike the old one that screams and howls in the cold weather.
20200301_131830.jpg
 

·
Registered
Joined
·
156 Posts
@heetseeker Thank you and to all that helped.

I installed new front shocks. While removing tire the screw on $24 Wilwood grease cap just plopped off.

Now I can’t for life of me get it back on. Supposed to be a finger tight rightytighty Install. There is no obvious thread wear. Any ideas? Thxs

Edit: I bought my Elky <1 year ago. A few months back, I bought new tires. My first time removing the wheel.
My Hucklebuckle Son fix is literally duct tape. I know it’ll melt and burn right off. I may have the wrong cap. May have been BFH smacked on?? Any ideas ?
 

Attachments

·
Registered
Joined
·
2,206 Posts
Just finished replacing the heater fan with a junkyard find (tested it before pulling the old one out). It's working good and runs quietly unlike the old one that screams and howls in the cold weather. View attachment 127963
You might try drilling a small hole in the and by the shaft and put some lightweight oil in it. Might solve a problem too
 

·
Registered
Joined
·
43 Posts
You might try drilling a small hole in the and by the shaft and put some lightweight oil in it. Might solve a problem too
Thank you for the tip. I will try that and see if it runs quietly. If it works, then I will still have a spare for another time. I already replaced it with the junkyard unit, but I forgot to clean the interior of the blower box of any dirt and tree litter that has passed through the screen over the last dozen years. That would be a good excuse to reinstall the original if the oil trick works.
 

·
Registered
Joined
·
43 Posts
How about "What have you done to your El Camino FRIEND today?"
I sent him a link to this website.
He got his elky from his cousin a few months ago. I told him about this site and he asked for the link. Hope to see him sign up.
 

·
Premium Member
Joined
·
7,671 Posts
I had problems with the battery again, the charger says it's charged. It's a new battery so I'll have to take it back and get another one.
 

·
Registered
Joined
·
3,447 Posts
actually got mine started.....and kept it running (miracle of miracles)...then actually drove it 5 miles at 9pm dead of night (took 20 mins, with the door cracked because the inside handle is broken off and the power window...doesn't...) over to where I'm going to pull the carb and send it off to ....Mountain Man (imagine hearing this said by the Wizard of Oz in a big thundery voice)

I can't remember the last time I heard such moaning and creaking going around corners and over road dips
 

·
Registered
Joined
·
13 Posts
Just got my 1985 Cho Cho back after extensive engine & paint work. The mechanic did the best he could but now have to take it to a carb man to finish up. Otherwise looks good.
 

·
Premium Member
Joined
·
597 Posts
Finally cleaned up and aimed my ‘68 headlights. I’ve had this for almost two years but only drove it in the dark For the first time last week. Holy cow; the low beams were pointing so low that I could just see two spots on the road over the hood. Turned out that the upper plastic adjuster nuts were stripped so the spring pressure on the buckets were just pulling them down as far as they would go. When I got all four headlights out I was surprised at just how much paint overspray was on the bulbs. So a couple of plastic adjuster nuts and an hour or so with some Goof Off and some Scotchbrite got me looking good again. I was really surprised that the headlights were pointing down so far and I couldn’t tell just by looking at them. The multiple front end angles really hid the misalignment, but the roadway sure told the story.
 

·
Registered
Joined
·
257 Posts
Hello Just received some parts got the piston put on, being I removed
my mirrors I had a hole where the remote was and the p.o put piston
door locks on so I have a piston lighter and valve caps. I also got my
81 Monte Carlo console from the G-Body Warehouse in R.I. Going to
take my time painting and getting it put in.
Everybody be safe. Russ
CIMG4969.JPG
CIMG4971.JPG
 

·
Registered
Joined
·
257 Posts
Joe I got it at the g-body Warehouse in R.I. He said it was out of a 1981 Monte Carlo
it has some burn marks by the breadbox door opening. Going to wait till it warms up to
smooth out burn marks and paint. I set it in the center to make sure it fits went for a ride
it didn't move so I might not bolt it down. Stay safe. Russ
 

·
Registered
Joined
·
156 Posts
Wow Thxs Russ. I’ve been looking for one and will check out that site. My car was originally a bench seat. It has late model Impala SS leather power seats. I’d prolly have to wedge it in there.

BTW, I love that steering wheel. Here’s mine:
6E23A740-51C6-422A-B8D4-7A7815BFF930.jpeg
 
4221 - 4240 of 4262 Posts
Top