El Camino Central Forum banner

1 - 20 of 81 Posts

·
Registered
Joined
·
158 Posts
Discussion Starter #1
so i just bought a elco yesterday i gave mine up and 200 dollars the one i got it has carb and intake both elderbrock everything looks clean on the car it ran good but today i thought i was running out of gas on the car. cause the gauges dont work...:poke: and i put 35 dollars it seemed like my car had no gas cause it felt it was running out of gas so i pumped the 35 and i still got the same problem so i went to autozone and got a carb cleaner..... samething. helpl!?!??!:dontknow:
 

·
Registered
Joined
·
134 Posts
is it just sputtering like its going to die or does it sound like timing is messed up? If it does it at idle, try tweaking the distributor a little while its running and see if that helps.
 

·
Acting Director, Region 13
Joined
·
2,048 Posts
Maybe fuel pump? Fuel filter?:dontknow:
Tim
 

·
Registered
Joined
·
134 Posts
could also be as simple as a carb adjustment
 
1

·
Guest
Joined
·
0 Posts
In mans terms,SPUTTERING is like when have diarrhea and you got that last little bit you're tryna push out and you get that sputtering sound....
Does your car sound like its gonna conk out?
 

·
Registered
Joined
·
109 Posts
clogged fuel filter or the needle could've got stuck open on that edelbrock especially if it doesn't have a good filter on it.
 

·
Registered
Joined
·
555 Posts
so i just bought a elco yesterday i gave mine up and 200 dollars the one i got it has carb and intake both elderbrock everything looks clean on the car it ran good but today i thought i was running out of gas on the car. cause the gauges dont work...:poke: and i put 35 dollars it seemed like my car had no gas cause it felt it was running out of gas so i pumped the 35 and i still got the same problem so i went to autozone and got a carb cleaner..... samething. helpl!?!??!:dontknow:
You said "it felt it was running out of gas."

Can you explain in more detail what was happening?
 

·
Premium Member
Joined
·
12,122 Posts
Fuel filter in the fuel line fitting, on the carb. Those filters getting clogged have helped sell a lot of un-need parts over the years !!
Take the fuel line off of the carb fitting. and the fitting out of the carb. The filter should be inside of the inner end of the fitting. It's just a round paper type filter, available at all auto parts stores.
If it still acts up, go from there.....
 

·
Registered
Joined
·
158 Posts
Discussion Starter #13
it idles fine.... and it runs fine after like 5-10 mins after that acts up like is not gettin gas or is about to turn off
 

·
Registered
Joined
·
158 Posts
Discussion Starter #15
wheres that located at? . this guy didnt take care of the elco and i also bought a new power steering pump. too
 

·
Venerated Member RIP
Joined
·
2,918 Posts
Make sure your gas cap is vented .sounds like it could be vapor lock.
Your gas cap??? its located under your gas cap door, left rear behind the wheel well. WHERE YOU PUT GAS IN. When your problem happens, open your gas cap and see if there is a 'wooshing' sound, vacuum pressure would indicate a gas cap venting problem.

GOOD LUCK
 

·
Registered
Joined
·
45 Posts
I vote for the fuel filter. It is cheap, and easy to change. They have also lined the pockets of many tow companies over the years!
 

·
Premium Member
Joined
·
1,324 Posts
Take off your air cleaner from the carb. Run it until you get your operating temp. NOW, check to make sure the choke isn't still engaged. If it is, use WD-40 on the choke connections that go into the carb. They could be hanging up, and a car trying to run with full choke doesn't run long.
 

·
Registered
Joined
·
158 Posts
was your vehicle sitting for along time not being used ?
my caballero sat unused for about 3 years . it had similar problem .
i replaced all the rubber fuel lines at the gas tank. and used compressed air to blow out the steel lines which are in great shape still . then i replaced the fuel pump as i thought maybe the rubber diaphragm had gone hard . as well as putting on a new filter and edelbrock carb i had from another project . now it runs great .
so on the cheap replacing the fuel pump cost me $28. and the fuel line and filter was another $15. and i think i paid $180 for the carb about 5 years ago in Carlisle .
good luck .
 

·
Registered
Joined
·
158 Posts
Discussion Starter #20
so i had the elco checked out yesterday the guy that checked it out told me it was the spark plugs cause there wore burned so we changed them. and he adjusted the carb too. still same problem so the next day i called diffrent guy he test drove it he said something with the valves are too loose or too tight.
 
1 - 20 of 81 Posts
Top